Upstream information

CVE-2017-15597 at MITRE

Description

An issue was discovered in Xen through 4.9.x. Grant copying code made an implication that any grant pin would be accompanied by a suitable page reference. Other portions of code, however, did not match up with that assumption. When such a grant copy operation is being done on a grant of a dying domain, the assumption turns out wrong. A malicious guest administrator can cause hypervisor memory corruption, most likely resulting in host crash and a Denial of Service. Privilege escalation and information leaks cannot be ruled out.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9 6.2
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C AV:L/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network Local
Access Complexity Low High
Authentication Single None
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  SUSE
Base Score 8.1
Vector AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1061075 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • xen >= 4.9.1_02-3.21.1
  • xen-libs >= 4.9.1_02-3.21.1
  • xen-tools-domU >= 4.9.1_02-3.21.1
Patchnames:
SUSE-CAASP-ALL-2017-1926
SUSE Linux Enterprise Desktop 12 SP2
  • xen >= 4.7.4_02-43.21.1
  • xen-libs >= 4.7.4_02-43.21.1
  • xen-libs-32bit >= 4.7.4_02-43.21.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1987
SUSE Linux Enterprise Desktop 12 SP3
  • xen >= 4.9.1_02-3.21.1
  • xen-libs >= 4.9.1_02-3.21.1
  • xen-libs-32bit >= 4.9.1_02-3.21.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1926
SUSE Linux Enterprise Point of Sale 11 SP3
  • xen >= 4.2.5_21-45.16.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.106.8-45.16.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.106.8-45.16.1
  • xen-libs >= 4.2.5_21-45.16.1
  • xen-tools-domU >= 4.2.5_21-45.16.1
Patchnames:
sleposp3-xen-13366
SUSE Linux Enterprise Server 11 SP3-LTSS
  • xen >= 4.2.5_21-45.16.1
  • xen-doc-html >= 4.2.5_21-45.16.1
  • xen-doc-pdf >= 4.2.5_21-45.16.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.106.8-45.16.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.106.8-45.16.1
  • xen-libs >= 4.2.5_21-45.16.1
  • xen-libs-32bit >= 4.2.5_21-45.16.1
  • xen-tools >= 4.2.5_21-45.16.1
  • xen-tools-domU >= 4.2.5_21-45.16.1
Patchnames:
slessp3-xen-13366
SUSE Linux Enterprise Server 11 SP4
  • xen >= 4.4.4_26-61.17.1
  • xen-doc-html >= 4.4.4_26-61.17.1
  • xen-kmp-default >= 4.4.4_26_3.0.101_108.13-61.17.1
  • xen-kmp-pae >= 4.4.4_26_3.0.101_108.13-61.17.1
  • xen-libs >= 4.4.4_26-61.17.1
  • xen-libs-32bit >= 4.4.4_26-61.17.1
  • xen-tools >= 4.4.4_26-61.17.1
  • xen-tools-domU >= 4.4.4_26-61.17.1
Patchnames:
slessp4-xen-13372
SUSE Linux Enterprise Server 12 SP1-LTSS
  • xen >= 4.5.5_20-22.36.3
  • xen-doc-html >= 4.5.5_20-22.36.3
  • xen-kmp-default >= 4.5.5_20_k3.12.74_60.64.63-22.36.3
  • xen-libs >= 4.5.5_20-22.36.3
  • xen-libs-32bit >= 4.5.5_20-22.36.3
  • xen-tools >= 4.5.5_20-22.36.3
  • xen-tools-domU >= 4.5.5_20-22.36.3
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-2013
SUSE Linux Enterprise Server 12 SP2
  • xen >= 4.7.4_02-43.21.1
  • xen-doc-html >= 4.7.4_02-43.21.1
  • xen-libs >= 4.7.4_02-43.21.1
  • xen-libs-32bit >= 4.7.4_02-43.21.1
  • xen-tools >= 4.7.4_02-43.21.1
  • xen-tools-domU >= 4.7.4_02-43.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1987
SUSE Linux Enterprise Server 12 SP3
  • xen >= 4.9.1_02-3.21.1
  • xen-doc-html >= 4.9.1_02-3.21.1
  • xen-libs >= 4.9.1_02-3.21.1
  • xen-libs-32bit >= 4.9.1_02-3.21.1
  • xen-tools >= 4.9.1_02-3.21.1
  • xen-tools-domU >= 4.9.1_02-3.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1926
SUSE Linux Enterprise Server 12-LTSS
  • xen >= 4.4.4_26-22.59.3
  • xen-doc-html >= 4.4.4_26-22.59.3
  • xen-kmp-default >= 4.4.4_26_k3.12.61_52.101-22.59.3
  • xen-libs >= 4.4.4_26-22.59.3
  • xen-libs-32bit >= 4.4.4_26-22.59.3
  • xen-tools >= 4.4.4_26-22.59.3
  • xen-tools-domU >= 4.4.4_26-22.59.3
Patchnames:
SUSE-SLE-SERVER-12-2017-2019
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • xen >= 4.2.5_21-45.16.1
  • xen-doc-html >= 4.2.5_21-45.16.1
  • xen-doc-pdf >= 4.2.5_21-45.16.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.106.8-45.16.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.106.8-45.16.1
  • xen-libs >= 4.2.5_21-45.16.1
  • xen-libs-32bit >= 4.2.5_21-45.16.1
  • xen-tools >= 4.2.5_21-45.16.1
  • xen-tools-domU >= 4.2.5_21-45.16.1
Patchnames:
slessp3-xen-13366
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xen >= 4.4.4_26-61.17.1
  • xen-doc-html >= 4.4.4_26-61.17.1
  • xen-kmp-default >= 4.4.4_26_3.0.101_108.13-61.17.1
  • xen-kmp-pae >= 4.4.4_26_3.0.101_108.13-61.17.1
  • xen-libs >= 4.4.4_26-61.17.1
  • xen-libs-32bit >= 4.4.4_26-61.17.1
  • xen-tools >= 4.4.4_26-61.17.1
  • xen-tools-domU >= 4.4.4_26-61.17.1
Patchnames:
slessp4-xen-13372
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • xen >= 4.5.5_20-22.36.3
  • xen-doc-html >= 4.5.5_20-22.36.3
  • xen-kmp-default >= 4.5.5_20_k3.12.74_60.64.63-22.36.3
  • xen-libs >= 4.5.5_20-22.36.3
  • xen-libs-32bit >= 4.5.5_20-22.36.3
  • xen-tools >= 4.5.5_20-22.36.3
  • xen-tools-domU >= 4.5.5_20-22.36.3
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-2013
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • xen >= 4.5.5_20-22.36.3
  • xen-doc-html >= 4.5.5_20-22.36.3
  • xen-kmp-default >= 4.5.5_20_k3.12.74_60.64.63-22.36.3
  • xen-libs >= 4.5.5_20-22.36.3
  • xen-libs-32bit >= 4.5.5_20-22.36.3
  • xen-tools >= 4.5.5_20-22.36.3
  • xen-tools-domU >= 4.5.5_20-22.36.3
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-2013
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • xen >= 4.7.4_02-43.21.1
  • xen-doc-html >= 4.7.4_02-43.21.1
  • xen-libs >= 4.7.4_02-43.21.1
  • xen-libs-32bit >= 4.7.4_02-43.21.1
  • xen-tools >= 4.7.4_02-43.21.1
  • xen-tools-domU >= 4.7.4_02-43.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1987
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • xen >= 4.9.1_02-3.21.1
  • xen-doc-html >= 4.9.1_02-3.21.1
  • xen-libs >= 4.9.1_02-3.21.1
  • xen-libs-32bit >= 4.9.1_02-3.21.1
  • xen-tools >= 4.9.1_02-3.21.1
  • xen-tools-domU >= 4.9.1_02-3.21.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1926
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • xen >= 4.4.4_26-22.59.3
  • xen-doc-html >= 4.4.4_26-22.59.3
  • xen-kmp-default >= 4.4.4_26_k3.12.61_52.101-22.59.3
  • xen-libs >= 4.4.4_26-22.59.3
  • xen-libs-32bit >= 4.4.4_26-22.59.3
  • xen-tools >= 4.4.4_26-22.59.3
  • xen-tools-domU >= 4.4.4_26-22.59.3
Patchnames:
SUSE-SLE-SERVER-12-2017-2019
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xen >= 4.4.4_26-61.17.1
  • xen-devel >= 4.4.4_26-61.17.1
Patchnames:
sdksp4-xen-13372
SUSE Linux Enterprise Software Development Kit 12 SP2
  • xen >= 4.7.4_02-43.21.1
  • xen-devel >= 4.7.4_02-43.21.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1987
SUSE Linux Enterprise Software Development Kit 12 SP3
  • xen >= 4.9.1_02-3.21.1
  • xen-devel >= 4.9.1_02-3.21.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1926
SUSE OpenStack Cloud 6
  • xen >= 4.5.5_20-22.36.3
  • xen-doc-html >= 4.5.5_20-22.36.3
  • xen-kmp-default >= 4.5.5_20_k3.12.74_60.64.63-22.36.3
  • xen-libs >= 4.5.5_20-22.36.3
  • xen-libs-32bit >= 4.5.5_20-22.36.3
  • xen-tools >= 4.5.5_20-22.36.3
  • xen-tools-domU >= 4.5.5_20-22.36.3
Patchnames:
SUSE-OpenStack-Cloud-6-2017-2013
openSUSE Leap 42.2
  • xen >= 4.7.4_02-11.21.1
  • xen-debugsource >= 4.7.4_02-11.21.1
  • xen-devel >= 4.7.4_02-11.21.1
  • xen-doc-html >= 4.7.4_02-11.21.1
  • xen-libs >= 4.7.4_02-11.21.1
  • xen-libs-32bit >= 4.7.4_02-11.21.1
  • xen-libs-debuginfo >= 4.7.4_02-11.21.1
  • xen-libs-debuginfo-32bit >= 4.7.4_02-11.21.1
  • xen-tools >= 4.7.4_02-11.21.1
  • xen-tools-debuginfo >= 4.7.4_02-11.21.1
  • xen-tools-domU >= 4.7.4_02-11.21.1
  • xen-tools-domU-debuginfo >= 4.7.4_02-11.21.1
Patchnames:
openSUSE-2017-1322
openSUSE Leap 42.3
  • xen >= 4.9.1_02-13.2
  • xen-debugsource >= 4.9.1_02-13.2
  • xen-devel >= 4.9.1_02-13.2
  • xen-doc-html >= 4.9.1_02-13.2
  • xen-libs >= 4.9.1_02-13.2
  • xen-libs-debuginfo >= 4.9.1_02-13.2
  • xen-tools >= 4.9.1_02-13.2
  • xen-tools-debuginfo >= 4.9.1_02-13.2
  • xen-tools-domU >= 4.9.1_02-13.2
  • xen-tools-domU-debuginfo >= 4.9.1_02-13.2
Patchnames:
openSUSE-2017-1321


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 xen Already fixed
CaaS Platform 2.0 xen Already fixed
SUSE Linux Enterprise Desktop 12 SP2 xen Released
SUSE Linux Enterprise Desktop 12 SP3 xen Already fixed
SUSE Linux Enterprise SDK 11 SP4 xen Released
SUSE Linux Enterprise SDK 12 SP2 xen Released
SUSE Linux Enterprise SDK 12 SP3 xen Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS xen Released
SUSE Linux Enterprise Server 11 SP4 xen Released
SUSE Linux Enterprise Server 12 GA LTSS xen Released
SUSE Linux Enterprise Server 12 SP1 LTSS xen Released
SUSE Linux Enterprise Server 12 SP2 xen Released
SUSE Linux Enterprise Server 12 SP3 xen Already fixed