Upstream information

CVE-2017-11171 at MITRE

Description

Bad reference counting in the context of accept_ice_connection() in gsm-xsmp-server.c in old versions of gnome-session up until version 2.29.92 allows a local attacker to establish ICE connections to gnome-session with invalid authentication data (an invalid magic cookie). Each failed authentication attempt will leak a file descriptor in gnome-session. When the maximum number of file descriptors is exhausted in the gnome-session process, it will enter an infinite loop trying to communicate without success, consuming 100% of the CPU. The graphical session associated with the gnome-session process will stop working correctly, because communication with gnome-session is no longer possible.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.9 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:C AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 4
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1025068 [RESOLVED / FIXED], 1048274 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • gnome-session >= 2.28.0-3.11.12.2
  • gnome-session-lang >= 2.28.0-3.11.12.2
Patchnames:
slessp4-gnome-session-13231


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 gnome-session Affected
HPE Helion OpenStack 8 libICE Affected
HPE Helion OpenStack 8 xorg-x11 Affected
SUSE Linux Enterprise Desktop 11 SP4 xorg-x11-libICE Released
SUSE Linux Enterprise Desktop 12 gnome-session Not affected
SUSE Linux Enterprise Desktop 12 libICE Affected
SUSE Linux Enterprise Desktop 12 xorg-x11 Affected
SUSE Linux Enterprise Desktop 12 SP1 gnome-session Not affected
SUSE Linux Enterprise Desktop 12 SP1 libICE Unsupported
SUSE Linux Enterprise Desktop 12 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Desktop 12 SP2 gnome-session Affected
SUSE Linux Enterprise Desktop 12 SP2 libICE Released
SUSE Linux Enterprise Desktop 12 SP2 xorg-x11 Affected
SUSE Linux Enterprise Desktop 12 SP3 gnome-session Affected
SUSE Linux Enterprise Desktop 12 SP3 libICE Released
SUSE Linux Enterprise Desktop 12 SP3 xorg-x11 Affected
SUSE Linux Enterprise Desktop 12 SP4 gnome-session Affected
SUSE Linux Enterprise Desktop 12 SP4 libICE Affected
SUSE Linux Enterprise Desktop 12 SP4 xorg-x11 Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libICE Released
SUSE Linux Enterprise Point of Service 11 SP3 gnome-session Released
SUSE Linux Enterprise Point of Service 11 SP3 xorg-x11-libICE Released
SUSE Linux Enterprise Server 11 SP3 gnome-session Affected
SUSE Linux Enterprise Server 11 SP3 xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP3 xorg-x11-libICE Affected
SUSE Linux Enterprise Server 11 SP3 LTSS gnome-session Affected
SUSE Linux Enterprise Server 11 SP3-LTSS gnome-session Affected
SUSE Linux Enterprise Server 11 SP3-LTSS xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS xorg-x11-libICE Affected
SUSE Linux Enterprise Server 11 SP4 gnome-session Released
SUSE Linux Enterprise Server 11 SP4 xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP4 xorg-x11-libICE Released
SUSE Linux Enterprise Server 11 SP4 LTSS gnome-session Released
SUSE Linux Enterprise Server 11 SP4 LTSS xorg-x11-libICE Released
SUSE Linux Enterprise Server 11 SP4-LTSS gnome-session Released
SUSE Linux Enterprise Server 11 SP4-LTSS xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS xorg-x11-libICE Released
SUSE Linux Enterprise Server 12 gnome-session Not affected
SUSE Linux Enterprise Server 12 libICE Affected
SUSE Linux Enterprise Server 12 xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP1 gnome-session Not affected
SUSE Linux Enterprise Server 12 SP1 libICE Unsupported
SUSE Linux Enterprise Server 12 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS gnome-session Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS libICE Affected
SUSE Linux Enterprise Server 12 SP1-LTSS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP2 gnome-session Not affected
SUSE Linux Enterprise Server 12 SP2 libICE Released
SUSE Linux Enterprise Server 12 SP2 xorg-x11 Not affected
SUSE Linux Enterprise Server 12 SP2-BCL gnome-session Affected
SUSE Linux Enterprise Server 12 SP2-BCL libICE Affected
SUSE Linux Enterprise Server 12 SP2-BCL xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS gnome-session Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libICE Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP2-LTSS gnome-session Affected
SUSE Linux Enterprise Server 12 SP2-LTSS libICE Affected
SUSE Linux Enterprise Server 12 SP2-LTSS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP3 gnome-session Affected
SUSE Linux Enterprise Server 12 SP3 libICE Released
SUSE Linux Enterprise Server 12 SP3 xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP3-BCL gnome-session Affected
SUSE Linux Enterprise Server 12 SP3-BCL libICE Affected
SUSE Linux Enterprise Server 12 SP3-BCL xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS gnome-session Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS libICE Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP3-LTSS gnome-session Affected
SUSE Linux Enterprise Server 12 SP3-LTSS libICE Affected
SUSE Linux Enterprise Server 12 SP3-LTSS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP4 gnome-session Affected
SUSE Linux Enterprise Server 12 SP4 libICE Affected
SUSE Linux Enterprise Server 12 SP4 xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS gnome-session Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libICE Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP4-LTSS gnome-session Affected
SUSE Linux Enterprise Server 12 SP4-LTSS libICE Affected
SUSE Linux Enterprise Server 12 SP4-LTSS xorg-x11 Affected
SUSE Linux Enterprise Server 12 SP5 gnome-session Affected
SUSE Linux Enterprise Server 12 SP5 libICE Released
SUSE Linux Enterprise Server 12 SP5 xorg-x11 Affected
SUSE Linux Enterprise Server 12-LTSS gnome-session Not affected
SUSE Linux Enterprise Server 12-LTSS libICE Affected
SUSE Linux Enterprise Server 12-LTSS xorg-x11 Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 gnome-session Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libICE Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 xorg-x11 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gnome-session Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 xorg-x11-libICE Released
SUSE Linux Enterprise Server for SAP Applications 12 libICE Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gnome-session Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libICE Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 xorg-x11 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gnome-session Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libICE Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 xorg-x11 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gnome-session Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libICE Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xorg-x11 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gnome-session Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libICE Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xorg-x11 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libICE Released
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 libICE Released
SUSE Linux Enterprise Software Development Kit 11 SP4 xorg-x11-libICE Released
SUSE Linux Enterprise Software Development Kit 12 libICE Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libICE Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 libICE Released
SUSE Linux Enterprise Software Development Kit 12 SP3 libICE Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libICE Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libICE Affected
SUSE OpenStack Cloud 7 gnome-session Affected
SUSE OpenStack Cloud 7 libICE Affected
SUSE OpenStack Cloud 7 xorg-x11 Affected
SUSE OpenStack Cloud 8 gnome-session Affected
SUSE OpenStack Cloud 8 libICE Affected
SUSE OpenStack Cloud 8 xorg-x11 Affected
SUSE OpenStack Cloud 9 gnome-session Affected
SUSE OpenStack Cloud 9 libICE Affected
SUSE OpenStack Cloud 9 xorg-x11 Affected
SUSE OpenStack Cloud Crowbar 8 gnome-session Affected
SUSE OpenStack Cloud Crowbar 8 libICE Affected
SUSE OpenStack Cloud Crowbar 8 xorg-x11 Affected
SUSE OpenStack Cloud Crowbar 9 gnome-session Affected
SUSE OpenStack Cloud Crowbar 9 libICE Affected
SUSE OpenStack Cloud Crowbar 9 xorg-x11 Affected


SUSE Timeline for this CVE

CVE page created: Mon Feb 13 18:15:44 2017
CVE page last modified: Tue Nov 29 14:09:33 2022