Upstream information

CVE-2016-5384 at MITRE

Description

fontconfig before 2.12.1 does not validate offsets, which allows local users to trigger arbitrary free calls and consequently conduct double free attacks and execute arbitrary code via a crafted cache file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.6 3.7
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:H/Au:N/C:P/I:P/A:P
Access Vector Local Local
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 992534 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • fontconfig >= 2.11.0-6.1
  • fontconfig-32bit >= 2.11.0-6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1294
SUSE Linux Enterprise Desktop 12 SP2
  • fontconfig >= 2.11.1-7.1
  • fontconfig-32bit >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA fontconfig
SUSE Linux Enterprise Desktop 12 SP3
  • fontconfig >= 2.11.1-7.1
  • fontconfig-32bit >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA fontconfig
SUSE Linux Enterprise Server 11 SP4
  • fontconfig >= 2.6.0-10.19.1
  • fontconfig-32bit >= 2.6.0-10.19.1
  • fontconfig-x86 >= 2.6.0-10.19.1
Patchnames:
slessp4-fontconfig-12719
SUSE Linux Enterprise Server 12 SP1
  • fontconfig >= 2.11.0-6.1
  • fontconfig-32bit >= 2.11.0-6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1294
SUSE Linux Enterprise Server 12 SP2
  • fontconfig >= 2.11.1-7.1
  • fontconfig-32bit >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA fontconfig
SUSE Linux Enterprise Server 12 SP3
  • fontconfig >= 2.11.1-7.1
  • fontconfig-32bit >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA fontconfig
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • fontconfig >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA fontconfig
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • fontconfig >= 2.6.0-10.19.1
  • fontconfig-32bit >= 2.6.0-10.19.1
  • fontconfig-x86 >= 2.6.0-10.19.1
Patchnames:
slessp4-fontconfig-12719
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • fontconfig >= 2.11.0-6.1
  • fontconfig-32bit >= 2.11.0-6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1294
SUSE Linux Enterprise Software Development Kit 11 SP4
  • fontconfig >= 2.6.0-10.19.1
  • fontconfig-devel >= 2.6.0-10.19.1
  • fontconfig-devel-32bit >= 2.6.0-10.19.1
Patchnames:
sdksp4-fontconfig-12719
SUSE Linux Enterprise Software Development Kit 12 SP1
  • fontconfig >= 2.11.0-6.1
  • fontconfig-devel >= 2.11.0-6.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1294
SUSE Linux Enterprise Software Development Kit 12 SP2
  • fontconfig-devel >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA fontconfig-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • fontconfig-devel >= 2.11.1-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA fontconfig-devel
openSUSE Leap 42.1
  • fontconfig >= 2.11.0-5.1
  • fontconfig-32bit >= 2.11.0-5.1
  • fontconfig-debuginfo >= 2.11.0-5.1
  • fontconfig-debuginfo-32bit >= 2.11.0-5.1
  • fontconfig-debugsource >= 2.11.0-5.1
  • fontconfig-devel >= 2.11.0-5.1
  • fontconfig-devel-32bit >= 2.11.0-5.1
Patchnames:
openSUSE-2016-1070
openSUSE Leap 42.2
  • fontconfig >= 2.11.1-2.2
  • fontconfig-32bit >= 2.11.1-2.2
  • fontconfig-devel >= 2.11.1-2.2
Patchnames:
openSUSE Leap 42.2 GA fontconfig
openSUSE Leap 42.3
  • fontconfig >= 2.11.1-4.3
  • fontconfig-32bit >= 2.11.1-4.3
  • fontconfig-devel >= 2.11.1-4.3
Patchnames:
openSUSE Leap 42.3 GA fontconfig


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP3 fontconfig Released
SUSE Linux Enterprise Desktop 11 SP4 fontconfig Released
SUSE Linux Enterprise Desktop 12 GA fontconfig Released
SUSE Linux Enterprise Desktop 12 SP1 fontconfig Released
SUSE Linux Enterprise Desktop 12 SP2 fontconfig Released
SUSE Linux Enterprise SDK 11 SP3 fontconfig Released
SUSE Linux Enterprise SDK 11 SP4 fontconfig Released
SUSE Linux Enterprise SDK 12 GA fontconfig Released
SUSE Linux Enterprise SDK 12 SP1 fontconfig Released
SUSE Linux Enterprise SDK 12 SP2 fontconfig Released
SUSE Linux Enterprise Server 10 SP4 LTSS fontconfig Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS fontconfig Not affected
SUSE Linux Enterprise Server 11 SP3 fontconfig Released
SUSE Linux Enterprise Server 11 SP3 LTSS fontconfig Released
SUSE Linux Enterprise Server 11 SP4 fontconfig Released
SUSE Linux Enterprise Server 12 GA fontconfig Released
SUSE Linux Enterprise Server 12 GA LTSS fontconfig Released
SUSE Linux Enterprise Server 12 SP1 fontconfig Released
SUSE Linux Enterprise Server 12 SP2 fontconfig Released
SUSE Linux Enterprise Server for VMWare 11 SP3 fontconfig Released