Upstream information

CVE-2016-3994 at MITRE

Description

The GIF loader in imlib2 before 1.4.9 allows remote attackers to cause a denial of service (application crash) or obtain sensitive information via a crafted image, which triggers an out-of-bounds read.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.42 6.42
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.2
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 973759 [RESOLVED / FIXED], 974879 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • imlib2 >= 1.4.2-2.20.1
  • imlib2-devel >= 1.4.2-2.20.1
  • imlib2-filters >= 1.4.2-2.20.1
  • imlib2-loaders >= 1.4.2-2.20.1
Patchnames:
sdksp4-imlib2-12595
openSUSE 13.2
  • imlib2 >= 1.4.9-17.4.1
  • imlib2-debuginfo >= 1.4.9-17.4.1
  • imlib2-debugsource >= 1.4.9-17.4.1
  • imlib2-devel >= 1.4.9-17.4.1
  • imlib2-filters >= 1.4.9-17.4.1
  • imlib2-filters-debuginfo >= 1.4.9-17.4.1
  • imlib2-loaders >= 1.4.9-17.4.1
  • imlib2-loaders-debuginfo >= 1.4.9-17.4.1
  • libImlib2-1 >= 1.4.9-17.4.1
  • libImlib2-1-debuginfo >= 1.4.9-17.4.1
Patchnames:
openSUSE-2016-600