Upstream information

CVE-2016-3627 at MITRE

Description

The xmlStringGetNodeList function in tree.c in libxml2 2.9.3 and earlier, when used in recovery mode, allows context-dependent attackers to cause a denial of service (infinite recursion, stack consumption, and application crash) via a crafted XML document.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 4.30
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 1026099 [RESOLVED / DUPLICATE], 1026101 [RESOLVED / DUPLICATE], 972335 [RESOLVED / FIXED], 975947 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libxml2 >= 2.9.1-20.1
  • libxml2-2 >= 2.9.1-20.1
  • libxml2-2-32bit >= 2.9.1-20.1
  • libxml2-tools >= 2.9.1-20.1
  • python-libxml2 >= 2.9.1-20.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-709
SUSE Linux Enterprise Desktop 12 SP1
  • libxml2 >= 2.9.1-20.1
  • libxml2-2 >= 2.9.1-20.1
  • libxml2-2-32bit >= 2.9.1-20.1
  • libxml2-tools >= 2.9.1-20.1
  • python-libxml2 >= 2.9.1-20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-709
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-2-32bit >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
  • python-libxml2 >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libxml2-2
SUSE Linux Enterprise Desktop 12 SP2 GA python-libxml2
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.40.1
  • libxml2-32bit >= 2.7.6-0.40.1
  • libxml2-doc >= 2.7.6-0.40.1
  • libxml2-python >= 2.7.6-0.40.3
  • libxml2-x86 >= 2.7.6-0.40.1
Patchnames:
slessp4-libxml2-12538
SUSE Linux Enterprise Server 12
  • libxml2 >= 2.9.1-20.1
  • libxml2-2 >= 2.9.1-20.1
  • libxml2-2-32bit >= 2.9.1-20.1
  • libxml2-doc >= 2.9.1-20.1
  • libxml2-tools >= 2.9.1-20.1
  • python-libxml2 >= 2.9.1-20.1
Patchnames:
SUSE-SLE-SERVER-12-2016-709
SUSE Linux Enterprise Server 12 SP1
  • libxml2 >= 2.9.1-20.1
  • libxml2-2 >= 2.9.1-20.1
  • libxml2-2-32bit >= 2.9.1-20.1
  • libxml2-doc >= 2.9.1-20.1
  • libxml2-tools >= 2.9.1-20.1
  • python-libxml2 >= 2.9.1-20.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-709
SUSE Linux Enterprise Server 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-2-32bit >= 2.9.4-27.1
  • libxml2-doc >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
  • python-libxml2 >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libxml2-2
SUSE Linux Enterprise Server 12 SP2 GA python-libxml2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2-2 >= 2.9.4-27.1
  • libxml2-doc >= 2.9.4-27.1
  • libxml2-tools >= 2.9.4-27.1
  • python-libxml2 >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libxml2-2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA python-libxml2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2 >= 2.7.6-0.40.1
  • libxml2-devel >= 2.7.6-0.40.1
  • libxml2-devel-32bit >= 2.7.6-0.40.1
Patchnames:
sdksp4-libxml2-12538
SUSE Linux Enterprise Software Development Kit 12
  • libxml2 >= 2.9.1-20.1
  • libxml2-devel >= 2.9.1-20.1
Patchnames:
SUSE-SLE-SDK-12-2016-709
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libxml2 >= 2.9.1-20.1
  • libxml2-devel >= 2.9.1-20.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-709
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2-devel >= 2.9.4-27.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libxml2-devel
openSUSE 13.2
  • libxml2 >= 2.9.4-7.17.1
  • libxml2-2 >= 2.9.4-7.17.1
  • libxml2-2-32bit >= 2.9.4-7.17.1
  • libxml2-2-debuginfo >= 2.9.4-7.17.1
  • libxml2-2-debuginfo-32bit >= 2.9.4-7.17.1
  • libxml2-debugsource >= 2.9.4-7.17.1
  • libxml2-devel >= 2.9.4-7.17.1
  • libxml2-devel-32bit >= 2.9.4-7.17.1
  • libxml2-doc >= 2.9.4-7.17.1
  • libxml2-tools >= 2.9.4-7.17.1
  • libxml2-tools-debuginfo >= 2.9.4-7.17.1
  • python-libxml2 >= 2.9.4-7.17.1
  • python-libxml2-debuginfo >= 2.9.4-7.17.1
  • python-libxml2-debugsource >= 2.9.4-7.17.1
Patchnames:
openSUSE-2016-662
openSUSE-2016-734
openSUSE Leap 42.1
  • libxml2 >= 2.9.1-16.1
  • libxml2-2 >= 2.9.1-16.1
  • libxml2-2-32bit >= 2.9.1-16.1
  • libxml2-2-debuginfo >= 2.9.1-16.1
  • libxml2-2-debuginfo-32bit >= 2.9.1-16.1
  • libxml2-debugsource >= 2.9.1-16.1
  • libxml2-devel >= 2.9.1-16.1
  • libxml2-devel-32bit >= 2.9.1-16.1
  • libxml2-doc >= 2.9.1-16.1
  • libxml2-tools >= 2.9.1-16.1
  • libxml2-tools-debuginfo >= 2.9.1-16.1
  • python-libxml2 >= 2.9.1-16.1
  • python-libxml2-debuginfo >= 2.9.1-16.1
  • python-libxml2-debugsource >= 2.9.1-16.1
Patchnames:
openSUSE-2016-583
openSUSE Leap 42.2
  • libxml2-2 >= 2.9.4-1.4
  • libxml2-2-32bit >= 2.9.4-1.4
  • libxml2-devel >= 2.9.4-1.4
  • libxml2-tools >= 2.9.4-1.4
  • python-libxml2 >= 2.9.4-1.3
Patchnames:
openSUSE Leap 42.2 GA libxml2-2
openSUSE Leap 42.2 GA python-libxml2
openSUSE Tumbleweed
  • libxml2-2 >= 2.9.4-1.22
  • libxml2-2-32bit >= 2.9.4-1.22
  • libxml2-devel >= 2.9.4-1.22
  • libxml2-devel-32bit >= 2.9.4-1.22
  • libxml2-doc >= 2.9.4-1.22
  • libxml2-tools >= 2.9.4-1.22
  • python-libxml2 >= 2.9.4-1.4
Patchnames:
openSUSE Tumbleweed GA libxml2-2
openSUSE Tumbleweed GA python-libxml2