Upstream information

CVE-2016-2381 at MITRE

Description

Perl might allow context-dependent attackers to bypass the taint protection mechanism in a child process via duplicate environment variables in envp.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 5.10
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 967082 [REOPENED], 992991 [RESOLVED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1326
SUSE Linux Enterprise Desktop 12 SP2
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA perl-32bit
SUSE Linux Enterprise Server 11 SP4
  • perl >= 5.10.0-64.80.1
  • perl-32bit >= 5.10.0-64.80.1
  • perl-Module-Build >= 0.2808.01-0.80.1
  • perl-Test-Simple >= 0.72-0.80.1
  • perl-base >= 5.10.0-64.80.1
  • perl-doc >= 5.10.0-64.80.1
  • perl-x86 >= 5.10.0-64.80.1
Patchnames:
slessp4-perl-12729
SUSE Linux Enterprise Server 12 SP1
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1326
SUSE Linux Enterprise Server 12 SP2
  • perl >= 5.18.2-11.1
  • perl-32bit >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA perl-32bit
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • perl >= 5.18.2-11.1
  • perl-base >= 5.18.2-11.1
  • perl-doc >= 5.18.2-11.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA perl
SUSE Linux Enterprise Software Development Kit 11 SP4
  • perl >= 5.10.0-64.80.1
  • perl-base-32bit >= 5.10.0-64.80.1
Patchnames:
sdksp4-perl-12729
openSUSE 13.2
  • perl >= 5.20.1-3.1
  • perl-32bit >= 5.20.1-3.1
  • perl-base >= 5.20.1-3.1
  • perl-base-32bit >= 5.20.1-3.1
  • perl-base-debuginfo >= 5.20.1-3.1
  • perl-base-debuginfo-32bit >= 5.20.1-3.1
  • perl-debuginfo >= 5.20.1-3.1
  • perl-debuginfo-32bit >= 5.20.1-3.1
  • perl-debugsource >= 5.20.1-3.1
  • perl-doc >= 5.20.1-3.1
Patchnames:
openSUSE-2016-386
openSUSE Leap 42.1
  • perl >= 5.18.2-5.1
  • perl-32bit >= 5.18.2-5.1
  • perl-base >= 5.18.2-5.1
  • perl-base-32bit >= 5.18.2-5.1
  • perl-base-debuginfo >= 5.18.2-5.1
  • perl-base-debuginfo-32bit >= 5.18.2-5.1
  • perl-debuginfo >= 5.18.2-5.1
  • perl-debuginfo-32bit >= 5.18.2-5.1
  • perl-debugsource >= 5.18.2-5.1
  • perl-doc >= 5.18.2-5.1
Patchnames:
openSUSE-2016-1086
openSUSE Leap 42.2
  • perl >= 5.18.2-5.6
  • perl-32bit >= 5.18.2-5.6
  • perl-base >= 5.18.2-5.6
  • perl-doc >= 5.18.2-5.6
Patchnames:
openSUSE Leap 42.2 GA perl-32bit


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Desktop 11 SP2
  • SUSE Linux Enterprise SDK 11 SP2
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Server 11 SP2
  • SUSE Linux Enterprise Server 11 SP2 LTSS
perl