Upstream information

CVE-2016-10253 at MITRE

Description

An issue was discovered in Erlang/OTP 18.x. Erlang's generation of compiled regular expressions is vulnerable to a heap overflow. Regular expressions using a malformed extpattern can indirectly specify an offset that is used as an array index. This ordinal permits arbitrary regions within the erts_alloc arena to be both read and written to.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 2.6
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
SUSE Bugzilla entry: 1030062 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12
  • erlang >= 18.3.4.7-9.1
  • erlang-debugger >= 18.3.4.7-9.1
  • erlang-debugger-src >= 18.3.4.7-9.1
  • erlang-debuginfo >= 18.3.4.7-9.1
  • erlang-debugsource >= 18.3.4.7-9.1
  • erlang-dialyzer >= 18.3.4.7-9.1
  • erlang-dialyzer-debuginfo >= 18.3.4.7-9.1
  • erlang-dialyzer-src >= 18.3.4.7-9.1
  • erlang-diameter >= 18.3.4.7-9.1
  • erlang-diameter-src >= 18.3.4.7-9.1
  • erlang-doc >= 18.3.4.7-9.1
  • erlang-epmd >= 18.3.4.7-9.1
  • erlang-epmd-debuginfo >= 18.3.4.7-9.1
  • erlang-et >= 18.3.4.7-9.1
  • erlang-et-src >= 18.3.4.7-9.1
  • erlang-gs >= 18.3.4.7-9.1
  • erlang-gs-src >= 18.3.4.7-9.1
  • erlang-jinterface >= 18.3.4.7-9.1
  • erlang-jinterface-src >= 18.3.4.7-9.1
  • erlang-observer >= 18.3.4.7-9.1
  • erlang-observer-src >= 18.3.4.7-9.1
  • erlang-reltool >= 18.3.4.7-9.1
  • erlang-reltool-src >= 18.3.4.7-9.1
  • erlang-src >= 18.3.4.7-9.1
  • erlang-wx >= 18.3.4.7-9.1
  • erlang-wx-debuginfo >= 18.3.4.7-9.1
  • erlang-wx-src >= 18.3.4.7-9.1
Patchnames:
openSUSE-2017-1358
openSUSE Leap 42.2
  • erlang >= 18.3.4.7-2.7.1
  • erlang-debugger >= 18.3.4.7-2.7.1
  • erlang-debugger-src >= 18.3.4.7-2.7.1
  • erlang-debuginfo >= 18.3.4.7-2.7.1
  • erlang-debugsource >= 18.3.4.7-2.7.1
  • erlang-dialyzer >= 18.3.4.7-2.7.1
  • erlang-dialyzer-debuginfo >= 18.3.4.7-2.7.1
  • erlang-dialyzer-src >= 18.3.4.7-2.7.1
  • erlang-diameter >= 18.3.4.7-2.7.1
  • erlang-diameter-src >= 18.3.4.7-2.7.1
  • erlang-doc >= 18.3.4.7-2.7.1
  • erlang-epmd >= 18.3.4.7-2.7.1
  • erlang-epmd-debuginfo >= 18.3.4.7-2.7.1
  • erlang-et >= 18.3.4.7-2.7.1
  • erlang-et-src >= 18.3.4.7-2.7.1
  • erlang-gs >= 18.3.4.7-2.7.1
  • erlang-gs-src >= 18.3.4.7-2.7.1
  • erlang-jinterface >= 18.3.4.7-2.7.1
  • erlang-jinterface-src >= 18.3.4.7-2.7.1
  • erlang-observer >= 18.3.4.7-2.7.1
  • erlang-observer-src >= 18.3.4.7-2.7.1
  • erlang-reltool >= 18.3.4.7-2.7.1
  • erlang-reltool-src >= 18.3.4.7-2.7.1
  • erlang-src >= 18.3.4.7-2.7.1
  • erlang-wx >= 18.3.4.7-2.7.1
  • erlang-wx-debuginfo >= 18.3.4.7-2.7.1
  • erlang-wx-src >= 18.3.4.7-2.7.1
Patchnames:
openSUSE-2017-1358
openSUSE Leap 42.3
  • erlang >= 18.3.4.7-6.1
  • erlang-debugger >= 18.3.4.7-6.1
  • erlang-debugger-src >= 18.3.4.7-6.1
  • erlang-debuginfo >= 18.3.4.7-6.1
  • erlang-debugsource >= 18.3.4.7-6.1
  • erlang-dialyzer >= 18.3.4.7-6.1
  • erlang-dialyzer-debuginfo >= 18.3.4.7-6.1
  • erlang-dialyzer-src >= 18.3.4.7-6.1
  • erlang-diameter >= 18.3.4.7-6.1
  • erlang-diameter-src >= 18.3.4.7-6.1
  • erlang-doc >= 18.3.4.7-6.1
  • erlang-epmd >= 18.3.4.7-6.1
  • erlang-epmd-debuginfo >= 18.3.4.7-6.1
  • erlang-et >= 18.3.4.7-6.1
  • erlang-et-src >= 18.3.4.7-6.1
  • erlang-gs >= 18.3.4.7-6.1
  • erlang-gs-src >= 18.3.4.7-6.1
  • erlang-jinterface >= 18.3.4.7-6.1
  • erlang-jinterface-src >= 18.3.4.7-6.1
  • erlang-observer >= 18.3.4.7-6.1
  • erlang-observer-src >= 18.3.4.7-6.1
  • erlang-reltool >= 18.3.4.7-6.1
  • erlang-reltool-src >= 18.3.4.7-6.1
  • erlang-src >= 18.3.4.7-6.1
  • erlang-wx >= 18.3.4.7-6.1
  • erlang-wx-debuginfo >= 18.3.4.7-6.1
  • erlang-wx-src >= 18.3.4.7-6.1
Patchnames:
openSUSE-2017-1358


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 5 erlang Affected
SUSE Openstack Cloud 6 erlang Affected
SUSE Openstack Cloud 7 erlang Affected
SUSE Storage 2.1 erlang Affected
SUSE Storage 3 erlang Affected
SUSE Storage 4 erlang Affected