Upstream information

CVE-2016-10164 at MITRE

Description

Multiple integer overflows in libXpm before 3.5.12, when a program requests parsing XPM extensions on a 64-bit platform, allow remote attackers to cause a denial of service (out-of-bounds write) or execute arbitrary code via (1) the number of extensions or (2) their concatenated length in a crafted XPM file, which triggers a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entry: 1021315 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-240
SUSE Linux Enterprise Desktop 12 SP2
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-240
SUSE Linux Enterprise Desktop 12 SP3
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libXpm4
SUSE Linux Enterprise Server 11 SP4
  • xorg-x11-libXpm >= 7.4-3.1
  • xorg-x11-libXpm-32bit >= 7.4-3.1
  • xorg-x11-libXpm-x86 >= 7.4-3.1
Patchnames:
slessp4-xorg-x11-libXpm-12988
SUSE Linux Enterprise Server 12 SP1
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-240
SUSE Linux Enterprise Server 12 SP2
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-240
SUSE Linux Enterprise Server 12 SP3
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libXpm4
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-240
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xorg-x11-libXpm >= 7.4-3.1
  • xorg-x11-libXpm-32bit >= 7.4-3.1
  • xorg-x11-libXpm-x86 >= 7.4-3.1
Patchnames:
slessp4-xorg-x11-libXpm-12988
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-240
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libXpm >= 3.5.11-5.1
  • libXpm4 >= 3.5.11-5.1
  • libXpm4-32bit >= 3.5.11-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-240
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-libXpm >= 7.4-3.1
  • xorg-x11-libXpm-devel >= 7.4-3.1
  • xorg-x11-libXpm-devel-32bit >= 7.4-3.1
Patchnames:
sdksp4-xorg-x11-libXpm-12988
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libXpm >= 3.5.11-5.1
  • libXpm-devel >= 3.5.11-5.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-240
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libXpm >= 3.5.11-5.1
  • libXpm-devel >= 3.5.11-5.1
  • libXpm-tools >= 3.5.11-5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-240
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libXpm-devel >= 3.5.11-5.1
  • libXpm-tools >= 3.5.11-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libXpm-devel
openSUSE Leap 42.1
  • libXpm >= 3.5.11-7.1
  • libXpm-debugsource >= 3.5.11-7.1
  • libXpm-devel >= 3.5.11-7.1
  • libXpm-devel-32bit >= 3.5.11-7.1
  • libXpm-tools >= 3.5.11-7.1
  • libXpm-tools-debuginfo >= 3.5.11-7.1
  • libXpm4 >= 3.5.11-7.1
  • libXpm4-32bit >= 3.5.11-7.1
  • libXpm4-debuginfo >= 3.5.11-7.1
  • libXpm4-debuginfo-32bit >= 3.5.11-7.1
Patchnames:
openSUSE-2017-292
openSUSE Leap 42.2
  • libXpm >= 3.5.11-8.1
  • libXpm-debugsource >= 3.5.11-8.1
  • libXpm-devel >= 3.5.11-8.1
  • libXpm-devel-32bit >= 3.5.11-8.1
  • libXpm-tools >= 3.5.11-8.1
  • libXpm-tools-debuginfo >= 3.5.11-8.1
  • libXpm4 >= 3.5.11-8.1
  • libXpm4-32bit >= 3.5.11-8.1
  • libXpm4-debuginfo >= 3.5.11-8.1
  • libXpm4-debuginfo-32bit >= 3.5.11-8.1
Patchnames:
openSUSE-2017-292
openSUSE Leap 42.3
  • libXpm-devel >= 3.5.11-11.3
  • libXpm4 >= 3.5.11-11.3
  • libXpm4-32bit >= 3.5.11-11.3
Patchnames:
openSUSE Leap 42.3 GA libXpm-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 libXpm Released
SUSE Linux Enterprise Desktop 12 SP2 libXpm Released
SUSE Linux Enterprise SDK 12 SP1 libXpm Released
SUSE Linux Enterprise SDK 12 SP2 libXpm Released
SUSE Linux Enterprise Server 12 SP1 libXpm Released
SUSE Linux Enterprise Server 12 SP2 libXpm Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libXpm Released