Upstream information

CVE-2016-10109 at MITRE

Description

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 6.1
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:L/AC:L/Au:N/C:P/I:P/A:C
Access Vector Network Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Complete
SUSE Bugzilla entry: 1017902 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libpcsclite1 >= 1.8.10-6.1
  • libpcsclite1-32bit >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-150
SUSE Linux Enterprise Desktop 12 SP3
  • libpcsclite1 >= 1.8.10-6.1
  • libpcsclite1-32bit >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libpcsclite1
SUSE Linux Enterprise Module for Basesystem 15
  • libpcsclite1 >= 1.8.23-2.27
  • libpcscspy0 >= 1.8.23-2.27
  • pcsc-lite >= 1.8.23-2.27
  • pcsc-lite-devel >= 1.8.23-2.27
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpcsclite1
SUSE Linux Enterprise Server 12 SP1
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-150
SUSE Linux Enterprise Server 12 SP2
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-150
SUSE Linux Enterprise Server 12 SP3
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libpcsclite1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-150
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-150
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libpcsclite1 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-150
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpcscspy0 >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
  • pcsc-lite-devel >= 1.8.10-6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-150
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpcscspy0 >= 1.8.10-6.1
  • pcsc-lite-devel >= 1.8.10-6.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libpcscspy0
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libpcsclite1-32bit >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-150
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libpcsclite1-32bit >= 1.8.10-6.1
  • pcsc-lite >= 1.8.10-6.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-150
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libpcsclite1-32bit >= 1.8.10-6.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libpcsclite1-32bit
openSUSE Leap 15.0
  • libpcsclite1 >= 1.8.23-lp150.2.1
  • pcsc-lite >= 1.8.23-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libpcsclite1
openSUSE Leap 42.1
  • libpcsclite1 >= 1.8.14-3.1
  • libpcsclite1-32bit >= 1.8.14-3.1
  • libpcsclite1-debuginfo >= 1.8.14-3.1
  • libpcsclite1-debuginfo-32bit >= 1.8.14-3.1
  • libpcscspy0 >= 1.8.14-3.1
  • libpcscspy0-32bit >= 1.8.14-3.1
  • libpcscspy0-debuginfo >= 1.8.14-3.1
  • libpcscspy0-debuginfo-32bit >= 1.8.14-3.1
  • pcsc-lite >= 1.8.14-3.1
  • pcsc-lite-debuginfo >= 1.8.14-3.1
  • pcsc-lite-debugsource >= 1.8.14-3.1
  • pcsc-lite-devel >= 1.8.14-3.1
Patchnames:
openSUSE-2017-106
openSUSE Leap 42.2
  • libpcsclite1 >= 1.8.17-3.1
  • libpcsclite1-32bit >= 1.8.17-3.1
  • libpcsclite1-debuginfo >= 1.8.17-3.1
  • libpcsclite1-debuginfo-32bit >= 1.8.17-3.1
  • libpcscspy0 >= 1.8.17-3.1
  • libpcscspy0-32bit >= 1.8.17-3.1
  • libpcscspy0-debuginfo >= 1.8.17-3.1
  • libpcscspy0-debuginfo-32bit >= 1.8.17-3.1
  • pcsc-lite >= 1.8.17-3.1
  • pcsc-lite-debuginfo >= 1.8.17-3.1
  • pcsc-lite-debugsource >= 1.8.17-3.1
  • pcsc-lite-devel >= 1.8.17-3.1
Patchnames:
openSUSE-2017-106
openSUSE Leap 42.3
  • libpcsclite1 >= 1.8.22-1.1
  • pcsc-lite >= 1.8.22-1.1
Patchnames:
openSUSE Leap 42.3 GA libpcsclite1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 pcsc-lite Affected
SUSE Linux Enterprise Desktop 12 SP2 pcsc-lite Released
SUSE Linux Enterprise SDK 11 SP4 pcsc-lite Not affected
SUSE Linux Enterprise SDK 12 SP1 pcsc-lite Affected
SUSE Linux Enterprise SDK 12 SP2 pcsc-lite Released
SUSE Linux Enterprise Server 11 SP4 pcsc-lite Not affected
SUSE Linux Enterprise Server 12 SP1 pcsc-lite Released
SUSE Linux Enterprise Server 12 SP2 pcsc-lite Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI pcsc-lite Released
SUSE Linux Enterprise Workstation Extension 12 SP1 pcsc-lite Released
SUSE Linux Enterprise Workstation Extension 12 SP2 pcsc-lite Released