Upstream information

CVE-2015-7552 at MITRE

Description

Heap-based buffer overflow in the gdk_pixbuf_flip function in gdk-pixbuf-scale.c in gdk-pixbuf 2.30.x allows remote attackers to cause a denial of service or possibly execute arbitrary code via a crafted BMP file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9.3 6
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None Single
Confidentiality Impact Complete Partial
Integrity Impact Complete Partial
Availability Impact Complete Partial
SUSE Bugzilla entry: 958963 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • gtk2 >= 2.18.9-0.39.1
  • gtk2-32bit >= 2.18.9-0.39.1
  • gtk2-devel >= 2.18.9-0.39.1
  • gtk2-devel-32bit >= 2.18.9-0.39.1
  • gtk2-lang >= 2.18.9-0.39.1
Patchnames:
sdksp3-gtk2-12376
sledsp3-gtk2-12376
SUSE Linux Enterprise Desktop 11 SP4
  • gtk2 >= 2.18.9-0.39.1
  • gtk2-32bit >= 2.18.9-0.39.1
  • gtk2-devel >= 2.18.9-0.39.1
  • gtk2-devel-32bit >= 2.18.9-0.39.1
  • gtk2-lang >= 2.18.9-0.39.1
Patchnames:
sdksp4-gtk2-12376
sledsp4-gtk2-12376
SUSE Linux Enterprise Desktop 12 SP1
  • gdk-pixbuf-devel >= 2.30.6-10.1
  • gdk-pixbuf-lang >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders-32bit >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0 >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.30.6-10.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.30.6-10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-140
SUSE-SLE-SDK-12-SP1-2016-140
SUSE Linux Enterprise Desktop 12 SP2
  • gdk-pixbuf-devel >= 2.34.0-16.2
  • gdk-pixbuf-lang >= 2.34.0-16.2
  • gdk-pixbuf-query-loaders >= 2.34.0-16.2
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-16.2
  • libgdk_pixbuf-2_0-0 >= 2.34.0-16.2
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-16.2
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-16.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA gdk-pixbuf-lang-2.34.0-16.2
SUSE Linux Enterprise Software Development Kit 12 SP2 GA gdk-pixbuf-devel-2.34.0-16.2
SUSE Linux Enterprise Desktop 12 SP3
  • gdk-pixbuf-devel >= 2.34.0-18.1
  • gdk-pixbuf-lang >= 2.34.0-18.1
  • gdk-pixbuf-query-loaders >= 2.34.0-18.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-18.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-18.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-18.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-18.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gdk-pixbuf-lang-2.34.0-18.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gdk-pixbuf-devel-2.34.0-18.1
SUSE Linux Enterprise Desktop 12 SP4
  • gdk-pixbuf-devel >= 2.34.0-19.17.1
  • gdk-pixbuf-lang >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.17.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.17.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gdk-pixbuf-lang-2.34.0-19.17.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gdk-pixbuf-devel-2.34.0-19.17.1
SUSE Linux Enterprise Desktop 12
  • gdk-pixbuf-devel >= 2.30.6-10.1
  • gdk-pixbuf-lang >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders-32bit >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0 >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.30.6-10.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.30.6-10.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-140
SUSE-SLE-SDK-12-2016-140
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Linux Enterprise Storage 6
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • gdk-pixbuf-devel >= 2.36.11-3.19
  • gdk-pixbuf-lang >= 2.36.11-3.19
  • gdk-pixbuf-query-loaders >= 2.36.11-3.19
  • gdk-pixbuf-query-loaders-32bit >= 2.36.11-3.19
  • gdk-pixbuf-thumbnailer >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0 >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0-32bit >= 2.36.11-3.19
  • typelib-1_0-GdkPixbuf-2_0 >= 2.36.11-3.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA gdk-pixbuf-devel-2.36.11-3.19
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA gdk-pixbuf-query-loaders-32bit-2.36.11-3.19
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • gdk-pixbuf-devel >= 2.40.0-1.25
  • gdk-pixbuf-lang >= 2.40.0-1.25
  • gdk-pixbuf-query-loaders >= 2.40.0-1.25
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-1.25
  • gdk-pixbuf-thumbnailer >= 2.40.0-1.25
  • libgdk_pixbuf-2_0-0 >= 2.40.0-1.25
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-1.25
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-1.25
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-1.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA gdk-pixbuf-devel-2.40.0-1.25
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA gdk-pixbuf-query-loaders-32bit-2.40.0-1.25
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • gdk-pixbuf-devel >= 2.40.0-3.3.1
  • gdk-pixbuf-lang >= 2.40.0-3.3.1
  • gdk-pixbuf-query-loaders >= 2.40.0-3.3.1
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-3.3.1
  • gdk-pixbuf-thumbnailer >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0 >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gdk-pixbuf-devel-2.40.0-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA gdk-pixbuf-query-loaders-32bit-2.40.0-3.3.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • gdk-pixbuf-devel >= 2.42.6-150400.3.8
  • gdk-pixbuf-lang >= 2.42.6-150400.3.8
  • gdk-pixbuf-query-loaders >= 2.42.6-150400.3.8
  • gdk-pixbuf-query-loaders-32bit >= 2.42.6-150400.3.8
  • gdk-pixbuf-thumbnailer >= 2.42.6-150400.3.8
  • libgdk_pixbuf-2_0-0 >= 2.42.6-150400.3.8
  • libgdk_pixbuf-2_0-0-32bit >= 2.42.6-150400.3.8
  • typelib-1_0-GdkPixbuf-2_0 >= 2.42.6-150400.3.8
  • typelib-1_0-GdkPixdata-2_0 >= 2.42.6-150400.3.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA gdk-pixbuf-devel-2.42.6-150400.3.8
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • gdk-pixbuf-devel >= 2.36.11-3.19
  • gdk-pixbuf-lang >= 2.36.11-3.19
  • gdk-pixbuf-query-loaders >= 2.36.11-3.19
  • gdk-pixbuf-query-loaders-32bit >= 2.36.11-3.19
  • gdk-pixbuf-thumbnailer >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0 >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0-32bit >= 2.36.11-3.19
  • typelib-1_0-GdkPixbuf-2_0 >= 2.36.11-3.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gdk-pixbuf-devel-2.36.11-3.19
SUSE Linux Enterprise Module for Desktop Applications 15 GA gdk-pixbuf-query-loaders-32bit-2.36.11-3.19
SUSE Linux Enterprise High Performance Computing 12 SP5
  • gdk-pixbuf-lang >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.17.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.17.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA gdk-pixbuf-lang-2.34.0-19.17.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • gdk-pixbuf-devel >= 2.36.11-3.19
  • gdk-pixbuf-lang >= 2.36.11-3.19
  • gdk-pixbuf-query-loaders >= 2.36.11-3.19
  • gdk-pixbuf-thumbnailer >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0 >= 2.36.11-3.19
  • typelib-1_0-GdkPixbuf-2_0 >= 2.36.11-3.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA gdk-pixbuf-devel-2.36.11-3.19
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • gdk-pixbuf-devel >= 2.40.0-1.25
  • gdk-pixbuf-lang >= 2.40.0-1.25
  • gdk-pixbuf-query-loaders >= 2.40.0-1.25
  • gdk-pixbuf-thumbnailer >= 2.40.0-1.25
  • libgdk_pixbuf-2_0-0 >= 2.40.0-1.25
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-1.25
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-1.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP2 GA gdk-pixbuf-devel-2.40.0-1.25
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • gdk-pixbuf-devel >= 2.40.0-3.3.1
  • gdk-pixbuf-lang >= 2.40.0-3.3.1
  • gdk-pixbuf-query-loaders >= 2.40.0-3.3.1
  • gdk-pixbuf-thumbnailer >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixdata-2_0 >= 2.40.0-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA gdk-pixbuf-devel-2.40.0-3.3.1
SUSE Linux Enterprise Module for Basesystem 15
  • gdk-pixbuf-devel >= 2.36.11-3.19
  • gdk-pixbuf-lang >= 2.36.11-3.19
  • gdk-pixbuf-query-loaders >= 2.36.11-3.19
  • gdk-pixbuf-thumbnailer >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0 >= 2.36.11-3.19
  • typelib-1_0-GdkPixbuf-2_0 >= 2.36.11-3.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gdk-pixbuf-devel-2.36.11-3.19
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gdk-pixbuf-query-loaders-32bit >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0-32bit >= 2.36.11-3.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA gdk-pixbuf-query-loaders-32bit-2.36.11-3.19
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-1.25
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-1.25
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA gdk-pixbuf-query-loaders-32bit-2.40.0-1.25
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • gdk-pixbuf-query-loaders-32bit >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.40.0-3.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA gdk-pixbuf-query-loaders-32bit-2.40.0-3.3.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • gdk-pixbuf-query-loaders-32bit >= 2.36.11-3.19
  • libgdk_pixbuf-2_0-0-32bit >= 2.36.11-3.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA gdk-pixbuf-query-loaders-32bit-2.36.11-3.19
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • gtk2 >= 2.18.9-0.39.1
  • gtk2-32bit >= 2.18.9-0.39.1
  • gtk2-devel >= 2.18.9-0.39.1
  • gtk2-devel-32bit >= 2.18.9-0.39.1
  • gtk2-doc >= 2.18.9-0.39.1
  • gtk2-lang >= 2.18.9-0.39.1
  • gtk2-x86 >= 2.18.9-0.39.1
Patchnames:
sdksp3-gtk2-12376
slessp3-gtk2-12376
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • gtk2 >= 2.18.9-0.39.1
  • gtk2-32bit >= 2.18.9-0.39.1
  • gtk2-devel >= 2.18.9-0.39.1
  • gtk2-devel-32bit >= 2.18.9-0.39.1
  • gtk2-doc >= 2.18.9-0.39.1
  • gtk2-lang >= 2.18.9-0.39.1
  • gtk2-x86 >= 2.18.9-0.39.1
Patchnames:
sdksp4-gtk2-12376
slessp4-gtk2-12376
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gdk-pixbuf-devel >= 2.30.6-10.1
  • gdk-pixbuf-lang >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders-32bit >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0 >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.30.6-10.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.30.6-10.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-140
SUSE-SLE-SERVER-12-SP1-2016-140
SUSE Linux Enterprise Server 12 SP2
  • gdk-pixbuf-devel >= 2.34.0-16.2
  • gdk-pixbuf-lang >= 2.34.0-16.2
  • gdk-pixbuf-query-loaders >= 2.34.0-16.2
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-16.2
  • libgdk_pixbuf-2_0-0 >= 2.34.0-16.2
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-16.2
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-16.2
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA gdk-pixbuf-lang-2.34.0-16.2
SUSE Linux Enterprise Software Development Kit 12 SP2 GA gdk-pixbuf-devel-2.34.0-16.2
SUSE Linux Enterprise Server 12 SP3
  • gdk-pixbuf-devel >= 2.34.0-18.1
  • gdk-pixbuf-lang >= 2.34.0-18.1
  • gdk-pixbuf-query-loaders >= 2.34.0-18.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-18.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-18.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-18.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-18.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gdk-pixbuf-lang-2.34.0-18.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gdk-pixbuf-devel-2.34.0-18.1
SUSE Linux Enterprise Server 12 SP4
  • gdk-pixbuf-devel >= 2.34.0-19.17.1
  • gdk-pixbuf-lang >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.17.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.17.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA gdk-pixbuf-lang-2.34.0-19.17.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gdk-pixbuf-devel-2.34.0-19.17.1
SUSE Linux Enterprise Server 12 SP5
  • gdk-pixbuf-devel >= 2.34.0-19.17.1
  • gdk-pixbuf-lang >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.17.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.17.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.17.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.17.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA gdk-pixbuf-lang-2.34.0-19.17.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gdk-pixbuf-devel-2.34.0-19.17.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • gdk-pixbuf-devel >= 2.30.6-10.1
  • gdk-pixbuf-lang >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders >= 2.30.6-10.1
  • gdk-pixbuf-query-loaders-32bit >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0 >= 2.30.6-10.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.30.6-10.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.30.6-10.1
Patchnames:
SUSE-SLE-SDK-12-2016-140
SUSE-SLE-SERVER-12-2016-140
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gdk-pixbuf-lang >= 2.34.0-16.2
  • gdk-pixbuf-query-loaders >= 2.34.0-16.2
  • libgdk_pixbuf-2_0-0 >= 2.34.0-16.2
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-16.2
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA gdk-pixbuf-lang-2.34.0-16.2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gdk-pixbuf-devel >= 2.34.0-16.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA gdk-pixbuf-devel-2.34.0-16.2
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gdk-pixbuf-devel >= 2.34.0-18.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gdk-pixbuf-devel-2.34.0-18.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • gdk-pixbuf-devel >= 2.34.0-19.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA gdk-pixbuf-devel-2.34.0-19.17.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • gdk-pixbuf-devel >= 2.34.0-19.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA gdk-pixbuf-devel-2.34.0-19.17.1
SUSE Linux Enterprise Software Development Kit 11 SP3
  • gtk2-devel >= 2.18.9-0.39.1
  • gtk2-devel-32bit >= 2.18.9-0.39.1
Patchnames:
sdksp3-gtk2-12376
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gtk2-devel >= 2.18.9-0.39.1
  • gtk2-devel-32bit >= 2.18.9-0.39.1
Patchnames:
sdksp4-gtk2-12376
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gdk-pixbuf-devel >= 2.30.6-10.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-140
SUSE Linux Enterprise Software Development Kit 12
  • gdk-pixbuf-devel >= 2.30.6-10.1
Patchnames:
SUSE-SLE-SDK-12-2016-140
openSUSE Leap 15.0
  • gdk-pixbuf-lang >= 2.36.11-lp150.3.4
  • gdk-pixbuf-query-loaders >= 2.36.11-lp150.3.4
  • gdk-pixbuf-thumbnailer >= 2.36.11-lp150.3.4
  • libgdk_pixbuf-2_0-0 >= 2.36.11-lp150.3.4
  • typelib-1_0-GdkPixbuf-2_0 >= 2.36.11-lp150.3.4
Patchnames:
openSUSE Leap 15.0 GA gdk-pixbuf-lang-2.36.11-lp150.3.4
openSUSE Leap 15.2
  • gdk-pixbuf-lang >= 2.40.0-lp152.1.6
  • gdk-pixbuf-query-loaders >= 2.40.0-lp152.1.6
  • gdk-pixbuf-thumbnailer >= 2.40.0-lp152.1.6
  • libgdk_pixbuf-2_0-0 >= 2.40.0-lp152.1.6
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-lp152.1.6
Patchnames:
openSUSE Leap 15.2 GA gdk-pixbuf-lang-2.40.0-lp152.1.2
openSUSE Leap 15.3
  • gdk-pixbuf-lang >= 2.40.0-3.3.1
  • gdk-pixbuf-query-loaders >= 2.40.0-3.3.1
  • gdk-pixbuf-thumbnailer >= 2.40.0-3.3.1
  • libgdk_pixbuf-2_0-0 >= 2.40.0-3.3.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.40.0-3.3.1
Patchnames:
openSUSE Leap 15.3 GA gdk-pixbuf-lang-2.40.0-3.3.1
openSUSE Leap 15.4
  • gdk-pixbuf-lang >= 2.42.6-150400.3.8
  • gdk-pixbuf-query-loaders >= 2.42.6-150400.3.8
  • gdk-pixbuf-thumbnailer >= 2.42.6-150400.3.8
  • libgdk_pixbuf-2_0-0 >= 2.42.6-150400.3.8
  • typelib-1_0-GdkPixbuf-2_0 >= 2.42.6-150400.3.8
Patchnames:
openSUSE Leap 15.4 GA gdk-pixbuf-lang-2.42.6-150400.3.8
openSUSE Tumbleweed
  • gdk-pixbuf-devel >= 2.36.0-1.1
  • gdk-pixbuf-devel-32bit >= 2.36.0-1.1
  • gdk-pixbuf-lang >= 2.36.0-1.1
  • gdk-pixbuf-query-loaders >= 2.36.0-1.1
  • gdk-pixbuf-query-loaders-32bit >= 2.36.0-1.1
  • libgdk_pixbuf-2_0-0 >= 2.36.0-1.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.36.0-1.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.36.0-1.1
Patchnames:
openSUSE Tumbleweed GA gdk-pixbuf-devel-2.36.0-1.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications gtk2 Released
SUSE Linux Enterprise Desktop 11 SP1 gtk2 Released
SUSE Linux Enterprise Desktop 11 SP2 gtk2 Released
SUSE Linux Enterprise Desktop 11 SP3 gdk-pixbuf Unsupported
SUSE Linux Enterprise Desktop 11 SP3 gtk2 Released
SUSE Linux Enterprise Desktop 11 SP4 gdk-pixbuf Unsupported
SUSE Linux Enterprise Desktop 11 SP4 gtk2 Released
SUSE Linux Enterprise Desktop 12 gdk-pixbuf Released
SUSE Linux Enterprise Desktop 12 gtk2 Not affected
SUSE Linux Enterprise Desktop 12 SP1 gdk-pixbuf Released
SUSE Linux Enterprise Desktop 12 SP1 gtk2 Unsupported
SUSE Linux Enterprise Point of Service 11 SP3 gtk2 Released
SUSE Linux Enterprise Server 11 SP1 LTSS gtk2 Released
SUSE Linux Enterprise Server 11 SP2 gtk2 Released
SUSE Linux Enterprise Server 11 SP2 LTSS gtk2 Released
SUSE Linux Enterprise Server 11 SP2 for VMware gtk2 Released
SUSE Linux Enterprise Server 11 SP3 gdk-pixbuf Unsupported
SUSE Linux Enterprise Server 11 SP3 gtk2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS gtk2 Released
SUSE Linux Enterprise Server 11 SP3 for VMware gtk2 Released
SUSE Linux Enterprise Server 11 SP4 gdk-pixbuf Unsupported
SUSE Linux Enterprise Server 11 SP4 gtk2 Released
SUSE Linux Enterprise Server 11 SP4 LTSS firefox-gdk-pixbuf In progress
SUSE Linux Enterprise Server 11 SP4 LTSS gtk2 Released
SUSE Linux Enterprise Server 12 gdk-pixbuf Released
SUSE Linux Enterprise Server 12 gtk2 Not affected
SUSE Linux Enterprise Server 12 SP1 gdk-pixbuf Released
SUSE Linux Enterprise Server 12 SP1 gtk2 Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP2 gtk2 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 gdk-pixbuf Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP3 gtk2 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gdk-pixbuf Unsupported
SUSE Linux Enterprise Server for SAP Applications 11 SP4 gtk2 Released
SUSE Linux Enterprise Server for SAP Applications 12 gdk-pixbuf Released
SUSE Linux Enterprise Server for SAP Applications 12 gtk2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 gdk-pixbuf Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gdk-pixbuf Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gtk2 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 gtk2 Released
SUSE Linux Enterprise Software Development Kit 11 SP3 gdk-pixbuf Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP3 gtk2 Released
SUSE Linux Enterprise Software Development Kit 11 SP4 gdk-pixbuf Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 gtk2 Released
SUSE Linux Enterprise Software Development Kit 12 gdk-pixbuf Released
SUSE Linux Enterprise Software Development Kit 12 gtk2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 gdk-pixbuf Released