Upstream information

CVE-2015-6031 at MITRE

Description

Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP servers to cause a denial of service (application crash) and possibly execute arbitrary code via an "oversized" XML element name.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 950759 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • libminiupnpc-devel >= 1.9-2.7.1
  • libminiupnpc10 >= 1.9-2.7.1
  • libminiupnpc10-debuginfo >= 1.9-2.7.1
  • miniupnpc >= 1.9-2.7.1
  • miniupnpc-debuginfo >= 1.9-2.7.1
  • python-miniupnpc >= 1.9-2.7.1
  • python-miniupnpc-debuginfo >= 1.9-2.7.1
Patchnames:
openSUSE-2015-789
openSUSE Leap 42.1
  • libminiupnpc-devel >= 1.9-6.1
  • libminiupnpc10 >= 1.9-6.1
  • libminiupnpc10-32bit >= 1.9-6.1
  • libminiupnpc10-debuginfo >= 1.9-6.1
  • libminiupnpc10-debuginfo-32bit >= 1.9-6.1
  • miniupnpc >= 1.9-6.1
  • miniupnpc-debuginfo >= 1.9-6.1
  • python-miniupnpc >= 1.9-6.1
  • python-miniupnpc-debuginfo >= 1.9-6.1
Patchnames:
openSUSE-2015-789
openSUSE Leap 42.2
  • libminiupnpc10 >= 1.9-6.14
Patchnames:
openSUSE Leap 42.2 GA libminiupnpc10
openSUSE Leap 42.3
  • libminiupnpc10 >= 1.9-9.4
Patchnames:
openSUSE Leap 42.3 GA libminiupnpc10