Upstream information

CVE-2015-1782 at MITRE

Description

The kex_agree_methods function in libssh2 before 1.5.0 allows remote servers to cause a denial of service (crash) or have other unspecified impact via crafted length values in an SSH_MSG_KEXINIT packet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 921070 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
Patchnames:
sledsp3-libssh2-1
SUSE Linux Enterprise Desktop 12
  • libssh2-1 >= 1.4.3-11.1
  • libssh2-1-32bit >= 1.4.3-11.1
  • libssh2_org >= 1.4.3-11.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-157
SUSE Linux Enterprise Desktop 12 SP1
  • libssh2-1 >= 1.4.3-11.1
  • libssh2-1-32bit >= 1.4.3-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libssh2-1
SUSE Linux Enterprise Desktop 12 SP2
  • libssh2-1 >= 1.4.3-19.1
  • libssh2-1-32bit >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libssh2-1
SUSE Linux Enterprise Desktop 12 SP3
  • libssh2-1 >= 1.4.3-19.1
  • libssh2-1-32bit >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libssh2-1
SUSE Linux Enterprise Module for Basesystem 15
  • libssh2-1 >= 1.8.0-2.35
  • libssh2-devel >= 1.8.0-2.35
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libssh2-1
SUSE Linux Enterprise Server 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
Patchnames:
slessp3-libssh2-1
SUSE Linux Enterprise Server 11 SP4
  • libssh2-1 >= 1.2.9-4.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libssh2-1
SUSE Linux Enterprise Server 12
  • libssh2-1 >= 1.4.3-11.1
  • libssh2-1-32bit >= 1.4.3-11.1
  • libssh2_org >= 1.4.3-11.1
Patchnames:
SUSE-SLE-SERVER-12-2015-157
SUSE Linux Enterprise Server 12 SP1
  • libssh2-1 >= 1.4.3-11.1
  • libssh2-1-32bit >= 1.4.3-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libssh2-1
SUSE Linux Enterprise Server 12 SP2
  • libssh2-1 >= 1.4.3-19.1
  • libssh2-1-32bit >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libssh2-1
SUSE Linux Enterprise Server 12 SP3
  • libssh2-1 >= 1.4.3-19.1
  • libssh2-1-32bit >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libssh2-1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libssh2-1 >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libssh2-1
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
Patchnames:
slessp3-libssh2-1
SUSE Linux Enterprise Server for SAP Applications 12
  • libssh2-1 >= 1.4.3-11.1
  • libssh2-1-32bit >= 1.4.3-11.1
  • libssh2_org >= 1.4.3-11.1
Patchnames:
SUSE-SLE-SERVER-12-2015-157
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
Patchnames:
slessp3-libssh2-1
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
  • libssh2-1-32bit >= 1.2.9-4.2.4.1
  • libssh2-1-x86 >= 1.2.9-4.2.4.1
  • libssh2-devel >= 1.2.9-4.2.4.1
Patchnames:
sdksp3-libssh2-1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libssh2-1 >= 1.2.9-4.2.4.1
  • libssh2-1-32bit >= 1.2.9-4.2.4.1
  • libssh2-1-x86 >= 1.2.9-4.2.4.1
  • libssh2-devel >= 1.2.9-4.2.4.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libssh2-1
SUSE Linux Enterprise Software Development Kit 12
  • libssh2-devel >= 1.4.3-11.1
  • libssh2_org >= 1.4.3-11.1
Patchnames:
SUSE-SLE-SDK-12-2015-157
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libssh2-devel >= 1.4.3-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libssh2-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libssh2-devel >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libssh2-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libssh2-devel >= 1.4.3-19.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libssh2-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
  • libssh2-devel >= 1.2.9-4.2.4.1
Builds
SAT Patch Nr: 10426
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libssh2-1-x86 >= 1.2.9-4.2.4.1
  • libssh2-devel >= 1.2.9-4.2.4.1
Builds
SAT Patch Nr: 10426
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libssh2-1-32bit >= 1.2.9-4.2.4.1
  • libssh2-devel >= 1.2.9-4.2.4.1
Builds
SAT Patch Nr: 10426
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libssh2-1 >= 1.2.9-4.2.4.1
  • libssh2-1-32bit >= 1.2.9-4.2.4.1
  • libssh2-devel >= 1.2.9-4.2.4.1
Builds
SAT Patch Nr: 10426
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libssh2-1 >= 1.2.9-4.2.4.1
Builds
SAT Patch Nr: 10426
openSUSE 13.1
  • libssh2-1 >= 1.5.0-7.4.1
  • libssh2-1-32bit >= 1.5.0-7.4.1
  • libssh2-1-debuginfo >= 1.5.0-7.4.1
  • libssh2-1-debuginfo-32bit >= 1.5.0-7.4.1
  • libssh2-devel >= 1.5.0-7.4.1
  • libssh2_org >= 1.5.0-7.4.1
  • libssh2_org-debugsource >= 1.5.0-7.4.1
Patchnames:
openSUSE-2015-242
openSUSE Leap 15.0
  • libssh2-1 >= 1.8.0-lp150.2.3
Patchnames:
openSUSE Leap 15.0 GA libssh2-1
openSUSE Leap 42.1
  • libssh2-1 >= 1.4.3-10.1
Patchnames:
openSUSE Leap 42.1 GA libssh2-1
openSUSE Leap 42.2
  • libssh2-1 >= 1.4.3-16.1
Patchnames:
openSUSE Leap 42.2 GA libssh2-1
openSUSE Leap 42.3
  • libssh2-1 >= 1.4.3-18.3
Patchnames:
openSUSE Leap 42.3 GA libssh2-1
openSUSE Tumbleweed
  • libssh2-1 >= 1.7.0-1.5
  • libssh2-1-32bit >= 1.7.0-1.5
  • libssh2-devel >= 1.7.0-1.5
Patchnames:
openSUSE Tumbleweed GA libssh2-1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 libssh2_org Released
SUSE Linux Enterprise Desktop 12 GA libssh2_org Released
SUSE Linux Enterprise Desktop 12 SP1 libssh2_org Released
SUSE Linux Enterprise SDK 11 SP4 libssh2_org Released
SUSE Linux Enterprise SDK 12 GA libssh2_org Released
SUSE Linux Enterprise SDK 12 SP1 libssh2_org Released
SUSE Linux Enterprise Server 11 SP2 LTSS libssh2_org Released
SUSE Linux Enterprise Server 11 SP3 LTSS libssh2_org Released
SUSE Linux Enterprise Server 11 SP4 libssh2_org Released
SUSE Linux Enterprise Server 12 GA libssh2_org Released
SUSE Linux Enterprise Server 12 SP1 libssh2_org Released