Upstream information

CVE-2015-1027 at MITRE

Description

The version checking subroutine in percona-toolkit before 2.2.13 and xtrabackup before 2.2.9 was vulnerable to silent HTTP downgrade attacks and Man In The Middle attacks in which the server response could be modified to allow the attacker to respond with modified command payload and have the client return additional running configuration information leading to an information disclosure of running configuration of MySQL.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 919298 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • percona-toolkit >= 2.2.13-2.14.1
  • xtrabackup >= 2.1.8-25.1
  • xtrabackup-debuginfo >= 2.1.8-25.1
  • xtrabackup-debugsource >= 2.1.8-25.1
Patchnames:
openSUSE-2015-217
openSUSE Tumbleweed
  • percona-toolkit >= 2.2.18-1.1
  • xtrabackup >= 2.3.5-1.3
  • xtrabackup-test >= 2.3.5-1.3
Patchnames:
openSUSE Tumbleweed GA percona-toolkit
openSUSE Tumbleweed GA xtrabackup