Upstream information

CVE-2014-9462 at MITRE

Description

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 923070 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • mercurial >= 2.3.2-0.9.2
Patchnames:
sdksp3-mercurial
SUSE Linux Enterprise Software Development Kit 11 SP4
  • mercurial >= 2.3.2-0.9.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA mercurial
SUSE Linux Enterprise Software Development Kit 12
  • mercurial >= 2.8.2-3.1
Patchnames:
SUSE-SLE-SDK-12-2015-184
SUSE Linux Enterprise Software Development Kit 12 SP1
  • mercurial >= 2.8.2-3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA mercurial
SUSE Linux Enterprise Software Development Kit 12 SP2
  • mercurial >= 2.8.2-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA mercurial
SUSE Linux Enterprise Software Development Kit 12 SP3
  • mercurial >= 2.8.2-14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA mercurial
SUSE Linux Enterprise Software Development Kit 11 SP3
  • mercurial >= 2.3.2-0.9.2
Builds
SAT Patch Nr: 10521
openSUSE 13.1
  • mercurial >= 2.7.1-2.4.1
  • mercurial-debuginfo >= 2.7.1-2.4.1
  • mercurial-debugsource >= 2.7.1-2.4.1
  • mercurial-lang >= 2.7.1-2.4.1
Patchnames:
openSUSE-2015-268


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP3 mercurial Released
SUSE Linux Enterprise SDK 11 SP4 mercurial Released
SUSE Linux Enterprise SDK 12 GA mercurial Released
SUSE Linux Enterprise SDK 12 SP1 mercurial Released