CVE-2014-1943

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-1943 at MITRE

Description

Fine Free file before 5.17 allows context-dependent attackers to cause a denial of service (infinite recursion, CPU consumption, and crash) via a crafted indirect offset value in the magic of a file.

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

SUSE information

SUSE Bugzilla entries: 864343, 864589, 883306

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • file >= 5.11-12.12.1
  • file-debuginfo >= 5.11-12.12.1
  • file-debugsource >= 5.11-12.12.1
  • file-devel >= 5.11-12.12.1
  • libmagic-data >= 5.11-12.12.1
  • libmagic1 >= 5.11-12.12.1
  • libmagic1-32bit >= 5.11-12.12.1
  • libmagic1-debuginfo >= 5.11-12.12.1
  • libmagic1-debuginfo-32bit >= 5.11-12.12.1
  • python-magic >= 5.11-12.12.1
Patchnames:
openSUSE-2014-209
openSUSE 13.1
  • file >= 5.15-4.16.1
  • file-debuginfo >= 5.15-4.16.1
  • file-debugsource >= 5.15-4.16.1
  • file-devel >= 5.15-4.16.1
  • file-magic >= 5.15-4.16.1
  • libmagic1 >= 5.15-4.16.1
  • libmagic1-32bit >= 5.15-4.16.1
  • libmagic1-debuginfo >= 5.15-4.16.1
  • libmagic1-debuginfo-32bit >= 5.15-4.16.1
  • python-magic >= 5.15-4.16.1
Patchnames:
openSUSE-2014-209
openSUSE Evergreen 11.4
  • file >= 5.04-16.1
  • file-32bit >= 5.04-16.1
  • file-debuginfo >= 5.04-16.1
  • file-debuginfo-32bit >= 5.04-16.1
  • file-debuginfo-x86 >= 5.04-16.1
  • file-debugsource >= 5.04-16.1
  • file-devel >= 5.04-16.1
  • file-x86 >= 5.04-16.1
  • python-magic >= 5.04-16.1
  • python-magic-debuginfo >= 5.04-16.1
  • python-magic-debugsource >= 5.04-16.1
Patchnames:
2014-31