CVE-2013-4852

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-4852 at MITRE

Description

Integer overflow in PuTTY 0.62 and earlier, WinSCP before 5.1.6, and other products that use PuTTY allows remote SSH servers to cause a denial of service (crash) and possibly execute arbitrary code in certain applications that use PuTTY via a negative size value in an RSA key signature during the SSH handshake, which triggers a heap-based buffer overflow.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

SUSE information

SUSE Bugzilla entries: 833567, 834202

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • filezilla >= 3.7.3-5.4.1
  • filezilla-debuginfo >= 3.7.3-5.4.1
  • filezilla-debugsource >= 3.7.3-5.4.1
  • filezilla-lang >= 3.7.3-5.4.1
  • putty >= 0.63-2.4.1
  • putty-debuginfo >= 0.63-2.4.1
  • putty-debugsource >= 0.63-2.4.1
Patchnames:
openSUSE-2013-650
openSUSE-2013-655