Upstream information

CVE-2013-4758 at MITRE

Description

Double free vulnerability in the writeDataError function in the ElasticSearch plugin (omelasticsearch) in rsyslog before 7.4.2 and before 7.5.2 devel, when errorfile is set to local logging, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted JSON response.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 828140 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • rsyslog >= 8.4.0-2.2
Patchnames:
SUSE Linux Enterprise Desktop 12 GA rsyslog
SUSE Linux Enterprise Desktop 12 SP1
  • rsyslog >= 8.4.0-8.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA rsyslog
SUSE Linux Enterprise Desktop 12 SP2
  • rsyslog >= 8.4.0-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA rsyslog
SUSE Linux Enterprise Desktop 12 SP3
  • rsyslog >= 8.24.0-1.20
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA rsyslog
SUSE Linux Enterprise Desktop 12 SP4
  • rsyslog >= 8.24.0-3.16.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA rsyslog
SUSE Linux Enterprise Module for Basesystem 15
  • rsyslog >= 8.33.1-1.30
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA rsyslog
SUSE Linux Enterprise Module for Server Applications 15
  • rsyslog-module-gssapi >= 8.33.1-1.30
  • rsyslog-module-mysql >= 8.33.1-1.30
  • rsyslog-module-pgsql >= 8.33.1-1.30
  • rsyslog-module-relp >= 8.33.1-1.30
  • rsyslog-module-snmp >= 8.33.1-1.30
  • rsyslog-module-udpspoof >= 8.33.1-1.30
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA rsyslog-module-gssapi
SUSE Linux Enterprise Server 12
  • rsyslog >= 8.4.0-2.2
  • rsyslog-diag-tools >= 8.4.0-2.2
  • rsyslog-doc >= 8.4.0-2.2
  • rsyslog-module-gssapi >= 8.4.0-2.2
  • rsyslog-module-gtls >= 8.4.0-2.2
  • rsyslog-module-mysql >= 8.4.0-2.2
  • rsyslog-module-pgsql >= 8.4.0-2.2
  • rsyslog-module-relp >= 8.4.0-2.2
  • rsyslog-module-snmp >= 8.4.0-2.2
  • rsyslog-module-udpspoof >= 8.4.0-2.2
Patchnames:
SUSE Linux Enterprise Server 12 GA rsyslog
SUSE Linux Enterprise Server 12 SP1
  • rsyslog >= 8.4.0-8.3
  • rsyslog-diag-tools >= 8.4.0-8.3
  • rsyslog-doc >= 8.4.0-8.3
  • rsyslog-module-gssapi >= 8.4.0-8.3
  • rsyslog-module-gtls >= 8.4.0-8.3
  • rsyslog-module-mysql >= 8.4.0-8.3
  • rsyslog-module-pgsql >= 8.4.0-8.3
  • rsyslog-module-relp >= 8.4.0-8.3
  • rsyslog-module-snmp >= 8.4.0-8.3
  • rsyslog-module-udpspoof >= 8.4.0-8.3
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA rsyslog
SUSE Linux Enterprise Server 12 SP2
  • rsyslog >= 8.4.0-14.1
  • rsyslog-diag-tools >= 8.4.0-14.1
  • rsyslog-doc >= 8.4.0-14.1
  • rsyslog-module-gssapi >= 8.4.0-14.1
  • rsyslog-module-gtls >= 8.4.0-14.1
  • rsyslog-module-mysql >= 8.4.0-14.1
  • rsyslog-module-pgsql >= 8.4.0-14.1
  • rsyslog-module-relp >= 8.4.0-14.1
  • rsyslog-module-snmp >= 8.4.0-14.1
  • rsyslog-module-udpspoof >= 8.4.0-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA rsyslog
SUSE Linux Enterprise Server 12 SP3
  • rsyslog >= 8.24.0-1.20
  • rsyslog-diag-tools >= 8.24.0-1.20
  • rsyslog-doc >= 8.24.0-1.20
  • rsyslog-module-gssapi >= 8.24.0-1.20
  • rsyslog-module-gtls >= 8.24.0-1.20
  • rsyslog-module-mysql >= 8.24.0-1.20
  • rsyslog-module-pgsql >= 8.24.0-1.20
  • rsyslog-module-relp >= 8.24.0-1.20
  • rsyslog-module-snmp >= 8.24.0-1.20
  • rsyslog-module-udpspoof >= 8.24.0-1.20
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA rsyslog
SUSE Linux Enterprise Server 12 SP4
  • rsyslog >= 8.24.0-3.16.1
  • rsyslog-diag-tools >= 8.24.0-3.16.1
  • rsyslog-doc >= 8.24.0-3.16.1
  • rsyslog-module-gssapi >= 8.24.0-3.16.1
  • rsyslog-module-gtls >= 8.24.0-3.16.1
  • rsyslog-module-mysql >= 8.24.0-3.16.1
  • rsyslog-module-pgsql >= 8.24.0-3.16.1
  • rsyslog-module-relp >= 8.24.0-3.16.1
  • rsyslog-module-snmp >= 8.24.0-3.16.1
  • rsyslog-module-udpspoof >= 8.24.0-3.16.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA rsyslog
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • rsyslog >= 8.4.0-14.1
  • rsyslog-diag-tools >= 8.4.0-14.1
  • rsyslog-doc >= 8.4.0-14.1
  • rsyslog-module-gssapi >= 8.4.0-14.1
  • rsyslog-module-gtls >= 8.4.0-14.1
  • rsyslog-module-mysql >= 8.4.0-14.1
  • rsyslog-module-pgsql >= 8.4.0-14.1
  • rsyslog-module-relp >= 8.4.0-14.1
  • rsyslog-module-snmp >= 8.4.0-14.1
  • rsyslog-module-udpspoof >= 8.4.0-14.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA rsyslog
openSUSE Leap 42.1
  • rsyslog >= 8.4.0-3.1
Patchnames:
openSUSE Leap 42.1 GA rsyslog
openSUSE Leap 42.3
  • rsyslog >= 8.24.0-1.3
Patchnames:
openSUSE Leap 42.3 GA rsyslog
openSUSE Tumbleweed
  • rsyslog >= 8.23.0-2.1
  • rsyslog-diag-tools >= 8.23.0-2.1
  • rsyslog-doc >= 8.23.0-2.1
  • rsyslog-module-dbi >= 8.23.0-2.1
  • rsyslog-module-elasticsearch >= 8.23.0-2.1
  • rsyslog-module-gcrypt >= 8.23.0-2.1
  • rsyslog-module-gssapi >= 8.23.0-2.1
  • rsyslog-module-gtls >= 8.23.0-2.1
  • rsyslog-module-guardtime >= 8.23.0-2.1
  • rsyslog-module-mmnormalize >= 8.23.0-2.1
  • rsyslog-module-mysql >= 8.23.0-2.1
  • rsyslog-module-omamqp1 >= 8.23.0-2.1
  • rsyslog-module-omhttpfs >= 8.23.0-2.1
  • rsyslog-module-omtcl >= 8.23.0-2.1
  • rsyslog-module-pgsql >= 8.23.0-2.1
  • rsyslog-module-relp >= 8.23.0-2.1
  • rsyslog-module-snmp >= 8.23.0-2.1
  • rsyslog-module-udpspoof >= 8.23.0-2.1
Patchnames:
openSUSE Tumbleweed GA rsyslog