Upstream information

CVE-2013-4474 at MITRE

Description

Format string vulnerability in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.3 allows remote attackers to cause a denial of service (crash) via format string specifiers in a destination filename.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 847907 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
openSUSE Leap 15.0
  • libpoppler-glib8 >= 0.62.0-lp150.2.5
  • libpoppler-qt5-1 >= 0.62.0-lp150.2.3
  • libpoppler73 >= 0.62.0-lp150.2.5
  • poppler-tools >= 0.62.0-lp150.2.5
Patchnames:
openSUSE Leap 15.0 GA libpoppler-glib8
openSUSE Leap 42.1
  • libpoppler-devel >= 0.24.4-5.3
  • libpoppler-glib8 >= 0.24.4-5.3
  • libpoppler-qt4-4 >= 0.24.4-5.2
  • libpoppler44 >= 0.24.4-5.3
  • poppler-tools >= 0.24.4-5.3
Patchnames:
openSUSE Leap 42.1 GA libpoppler-devel
openSUSE Leap 42.2
  • libpoppler-cpp0 >= 0.43.0-1.3
  • libpoppler-devel >= 0.43.0-1.3
  • libpoppler-glib8 >= 0.43.0-1.3
  • libpoppler-qt4-4 >= 0.43.0-1.1
  • libpoppler-qt5-1 >= 0.43.0-1.3
  • libpoppler-qt5-devel >= 0.43.0-1.3
  • libpoppler60 >= 0.43.0-1.3
  • poppler-tools >= 0.43.0-1.3
Patchnames:
openSUSE Leap 42.2 GA libpoppler-cpp0
openSUSE Leap 42.3
  • libpoppler-cpp0 >= 0.43.0-3.5
  • libpoppler-devel >= 0.43.0-3.5
  • libpoppler-glib8 >= 0.43.0-3.5
  • libpoppler-qt5-1 >= 0.43.0-3.5
  • libpoppler-qt5-devel >= 0.43.0-3.5
  • libpoppler60 >= 0.43.0-3.5
  • poppler-tools >= 0.43.0-3.5
Patchnames:
openSUSE Leap 42.3 GA libpoppler-cpp0
openSUSE Tumbleweed
  • libpoppler-cpp0 >= 0.49.0-1.1
  • libpoppler-cpp0-32bit >= 0.49.0-1.1
  • libpoppler-devel >= 0.49.0-1.1
  • libpoppler-glib-devel >= 0.49.0-1.1
  • libpoppler-glib8 >= 0.49.0-1.1
  • libpoppler-glib8-32bit >= 0.49.0-1.1
  • libpoppler-qt4-4 >= 0.49.0-1.1
  • libpoppler-qt4-4-32bit >= 0.49.0-1.1
  • libpoppler-qt4-devel >= 0.49.0-1.1
  • libpoppler-qt5-1 >= 0.49.0-1.1
  • libpoppler-qt5-1-32bit >= 0.49.0-1.1
  • libpoppler-qt5-devel >= 0.49.0-1.1
  • libpoppler65 >= 0.49.0-1.1
  • libpoppler65-32bit >= 0.49.0-1.1
  • poppler-tools >= 0.49.0-1.1
  • typelib-1_0-Poppler-0_18 >= 0.49.0-1.1
Patchnames:
openSUSE Tumbleweed GA libpoppler-cpp0