CVE-2013-4421

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-4421 at MITRE

Description

The buf_decompress function in packet.c in Dropbear SSH Server before 2013.59 allows remote attackers to cause a denial of service (memory consumption) via a compressed packet that has a large size when it is decompressed.

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

SUSE information

SUSE Bugzilla entry: 845306

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • dropbear >= 2013.60-7.4.1
  • dropbear-debuginfo >= 2013.60-7.4.1
  • dropbear-debugsource >= 2013.60-7.4.1
Patchnames:
openSUSE-2013-811
openSUSE 13.1
  • dropbear >= 2013.60-2.4.1
  • dropbear-debuginfo >= 2013.60-2.4.1
  • dropbear-debugsource >= 2013.60-2.4.1
Patchnames:
openSUSE-2013-839