Upstream information

CVE-2013-3565 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in the HTTP Interface in VideoLAN VLC Media Player before 2.0.7 allow remote attackers to inject arbitrary web script or HTML via the (1) command parameter to requests/vlm_cmd.xml, (2) dir parameter to requests/browse.xml, or (3) URI in a request, which is returned in an error message through share/lua/intf/http.lua.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 864422 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • libvlc5 >= 2.1.3-10.1
  • libvlc5-debuginfo >= 2.1.3-10.1
  • libvlccore7 >= 2.1.3-10.1
  • libvlccore7-debuginfo >= 2.1.3-10.1
  • vlc >= 2.1.3-10.1
  • vlc-debuginfo >= 2.1.3-10.1
  • vlc-debugsource >= 2.1.3-10.1
  • vlc-devel >= 2.1.3-10.1
  • vlc-gnome >= 2.1.3-10.1
  • vlc-gnome-debuginfo >= 2.1.3-10.1
  • vlc-noX >= 2.1.3-10.1
  • vlc-noX-debuginfo >= 2.1.3-10.1
  • vlc-noX-lang >= 2.1.3-10.1
  • vlc-qt >= 2.1.3-10.1
  • vlc-qt-debuginfo >= 2.1.3-10.1
Patchnames:
openSUSE-2014-178