Upstream information

CVE-2013-2070 at MITRE

Description

http/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5.8 6.4
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
SUSE Bugzilla entry: 821184 [CLOSED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
  • nginx >= 1.14.0-1.14
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA nginx
openSUSE 12.3
  • nginx >= 1.2.9-3.4.1
  • nginx-debuginfo >= 1.2.9-3.4.1
  • nginx-debugsource >= 1.2.9-3.4.1
Patchnames:
openSUSE-2013-484
openSUSE Tumbleweed
  • nginx >= 1.11.4-2.5
  • vim-plugin-nginx >= 1.11.4-2.5
Patchnames:
openSUSE Tumbleweed GA nginx


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 nginx-1.0 Not affected
SUSE Studio Onsite 1.3 nginx-1.0 Not affected