Upstream information

CVE-2013-0211 at MITRE

Description

Integer signedness error in the archive_write_zip_data function in archive_write_set_format_zip.c in libarchive 3.1.2 and earlier, when running on 64-bit machines, allows context-dependent attackers to cause a denial of service (crash) via unspecified vectors, which triggers an improper conversion between unsigned and signed types, leading to a buffer overflow.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 800024 [RESOLVED], 979005 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libarchive >= 3.1.2-9.1
  • libarchive13 >= 3.1.2-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-155
SUSE Linux Enterprise Desktop 12 SP1
  • libarchive13 >= 3.1.2-9.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libarchive13
SUSE Linux Enterprise Desktop 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libarchive13
SUSE Linux Enterprise Desktop 12 SP3
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libarchive13
SUSE Linux Enterprise Module for Basesystem 15
  • libarchive-devel >= 3.3.2-1.27
  • libarchive13 >= 3.3.2-1.27
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libarchive-devel
SUSE Linux Enterprise Module for Development Tools 15
  • bsdtar >= 3.3.2-1.27
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA bsdtar
SUSE Linux Enterprise Server 12
  • libarchive >= 3.1.2-9.1
  • libarchive13 >= 3.1.2-9.1
Patchnames:
SUSE-SLE-SERVER-12-2015-155
SUSE Linux Enterprise Server 12 SP1
  • libarchive13 >= 3.1.2-9.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libarchive13
SUSE Linux Enterprise Server 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libarchive13
SUSE Linux Enterprise Server 12 SP3
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libarchive13
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libarchive13 >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libarchive13
SUSE Linux Enterprise Server for SAP Applications 12
  • libarchive >= 3.1.2-9.1
  • libarchive13 >= 3.1.2-9.1
Patchnames:
SUSE-SLE-SERVER-12-2015-155
SUSE Linux Enterprise Software Development Kit 12
  • libarchive >= 3.1.2-9.1
  • libarchive-devel >= 3.1.2-9.1
Patchnames:
SUSE-SLE-SDK-12-2015-155
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libarchive-devel >= 3.1.2-9.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libarchive-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libarchive-devel >= 3.1.2-22.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libarchive-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libarchive-devel >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel
openSUSE 13.1
  • bsdtar >= 3.1.2-3.5.1
  • bsdtar-debuginfo >= 3.1.2-3.5.1
  • libarchive >= 3.1.2-3.5.1
  • libarchive-debugsource >= 3.1.2-3.5.1
  • libarchive-devel >= 3.1.2-3.5.1
  • libarchive13 >= 3.1.2-3.5.1
  • libarchive13-32bit >= 3.1.2-3.5.1
  • libarchive13-debuginfo >= 3.1.2-3.5.1
  • libarchive13-debuginfo-32bit >= 3.1.2-3.5.1
Patchnames:
openSUSE-2015-248
openSUSE Leap 15.0
  • libarchive13 >= 3.3.2-lp150.1.9
Patchnames:
openSUSE Leap 15.0 GA libarchive13
openSUSE Leap 42.1
  • bsdtar >= 3.1.2-8.1
  • libarchive-devel >= 3.1.2-8.1
  • libarchive13 >= 3.1.2-8.1
Patchnames:
openSUSE Leap 42.1 GA bsdtar
openSUSE Leap 42.2
  • bsdtar >= 3.1.2-14.1
  • libarchive-devel >= 3.1.2-14.1
  • libarchive13 >= 3.1.2-14.1
Patchnames:
openSUSE Leap 42.2 GA bsdtar
openSUSE Leap 42.3
  • bsdtar >= 3.1.2-19.3
  • libarchive-devel >= 3.1.2-19.3
  • libarchive13 >= 3.1.2-19.3
Patchnames:
openSUSE Leap 42.3 GA bsdtar
openSUSE Tumbleweed
  • bsdtar >= 3.2.2-2.1
  • libarchive-devel >= 3.2.2-2.1
  • libarchive13 >= 3.2.2-2.1
  • libarchive13-32bit >= 3.2.2-2.1
Patchnames:
openSUSE Tumbleweed GA bsdtar


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 bsdtar Affected
SUSE Linux Enterprise Desktop 11 SP2 bsdtar Ignore
SUSE Linux Enterprise Desktop 11 SP3 bsdtar Ignore
SUSE Linux Enterprise Desktop 12 GA libarchive Released
SUSE Linux Enterprise SDK 11 SP1 bsdtar Affected
SUSE Linux Enterprise SDK 11 SP2 bsdtar Ignore
SUSE Linux Enterprise SDK 11 SP3 bsdtar Ignore
SUSE Linux Enterprise SDK 12 GA libarchive Released
SUSE Linux Enterprise Server 11 SP1 bsdtar Affected
SUSE Linux Enterprise Server 11 SP1 LTSS bsdtar Affected
SUSE Linux Enterprise Server 11 SP2 bsdtar Ignore
SUSE Linux Enterprise Server 11 SP2 LTSS bsdtar Ignore
SUSE Linux Enterprise Server 11 SP3 bsdtar Ignore
SUSE Linux Enterprise Server 12 GA libarchive Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 bsdtar Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 bsdtar Ignore
SUSE Linux Enterprise Server for VMWare 11 SP3 bsdtar Ignore
SUSE Studio Onsite 1.3 bsdtar Affected