Upstream information

CVE-2012-0698 at MITRE

Description

tcsd in TrouSerS before 0.3.10 allows remote attackers to cause a denial of service (daemon crash) via a crafted type_offset value in a TCP packet to port 30003.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 791029 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP3
  • libtspi1 >= 0.3.10-0.9.50
  • libtspi1-32bit >= 0.3.10-0.9.50
  • libtspi1-x86 >= 0.3.10-0.9.50
  • trousers >= 0.3.10-0.9.50
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libtspi1
SUSE Linux Enterprise Server 11 SP4
  • libtspi1 >= 0.3.10-0.11.1
  • libtspi1-32bit >= 0.3.10-0.11.1
  • libtspi1-x86 >= 0.3.10-0.11.1
  • trousers >= 0.3.10-0.11.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libtspi1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • trousers-devel >= 0.3.10-0.11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA trousers-devel
SUSE Linux Enterprise Software Development Kit 11 SP2
  • trousers-devel >= 0.3.7-3.9.1
Builds
SAT Patch Nr: 7259
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libtspi1 >= 0.3.7-3.9.1
  • trousers >= 0.3.7-3.9.1
Builds
SAT Patch Nr: 7259
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libtspi1 >= 0.3.7-3.9.1
  • libtspi1-32bit >= 0.3.7-3.9.1
  • trousers >= 0.3.7-3.9.1
Builds
SAT Patch Nr: 7259
SUSE Linux Enterprise Server 11 SP2
  • libtspi1 >= 0.3.7-3.9.1
  • libtspi1-x86 >= 0.3.7-3.9.1
  • trousers >= 0.3.7-3.9.1
Builds
SAT Patch Nr: 7259


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 trousers Affected
SUSE Linux Enterprise Desktop 11 SP2 trousers Released
SUSE Linux Enterprise SDK 11 SP1 trousers Affected
SUSE Linux Enterprise SDK 11 SP2 trousers Released
SUSE Linux Enterprise Server 11 SP1 trousers Affected
SUSE Linux Enterprise Server 11 SP1 LTSS trousers Affected
SUSE Linux Enterprise Server 11 SP2 trousers Released
SUSE Linux Enterprise Server 11 SP2 LTSS trousers Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 trousers Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 trousers Released