Upstream information

CVE-2011-2709 at MITRE

Description

libgssapi and libgssglue before 0.4 do not properly check privileges, which allows local users to load untrusted configuration files and execute arbitrary code via the GSSAPI_MECH_CONF environment variable, as demonstrated using mount.nfs.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.2
Vector AV:L/AC:H/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 694598 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libgssglue1
SUSE Linux Enterprise Desktop 12 SP1
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libgssglue1
SUSE Linux Enterprise Desktop 12 SP2
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libgssglue1
SUSE Linux Enterprise Desktop 12 SP3
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libgssglue1
SUSE Linux Enterprise Server 12
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Server 12 GA libgssglue1
SUSE Linux Enterprise Server 12 SP1
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libgssglue1
SUSE Linux Enterprise Server 12 SP2
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libgssglue1
SUSE Linux Enterprise Server 12 SP3
  • libgssglue1 >= 0.4-3.83
  • libgssglue1-32bit >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libgssglue1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libgssglue1 >= 0.4-3.76
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libgssglue1
SUSE Linux Enterprise Software Development Kit 12
  • libgssglue-devel >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libgssglue-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgssglue-devel >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libgssglue-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libgssglue-devel >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libgssglue-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgssglue-devel >= 0.4-3.83
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libgssglue-devel
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • libgssapi >= 0.6-13.12.1
sles10-sp4.ppc
sled10-sp4.x86
sles10-sp4.s390x
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ia64
sles10-sp4.x86-64
ZYPP Patch Nr: 7541
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • libgssapi >= 0.6-13.12.1
  • libgssapi-32bit >= 0.6-13.12.1
sles10-sp4.ppc
sled10-sp4.x86
sles10-sp4.s390x
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ia64
sles10-sp4.x86-64
ZYPP Patch Nr: 7541
SUSE Linux Enterprise Server 10 SP4 for IPF
  • libgssapi >= 0.6-13.12.1
  • libgssapi-x86 >= 0.6-13.12.1
sles10-sp4.ppc
sled10-sp4.x86
sles10-sp4.s390x
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ia64
sles10-sp4.x86-64
ZYPP Patch Nr: 7541
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • libgssapi >= 0.6-13.12.1
  • libgssapi-64bit >= 0.6-13.12.1
sles10-sp4.ppc
sled10-sp4.x86
sles10-sp4.s390x
sled10-sp4.x86-64
sles10-sp4.x86
sles10-sp4.ia64
sles10-sp4.x86-64
ZYPP Patch Nr: 7541
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • libgssapi >= 0.6-13.12.1
  • libgssapi-32bit >= 0.6-13.12.1
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.s390x
sles10-sp3.ia64
ZYPP Patch Nr: 7544
SUSE Linux Enterprise Server 10 SP3
  • libgssapi >= 0.6-13.12.1
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.s390x
sles10-sp3.ia64
ZYPP Patch Nr: 7544
SUSE Linux Enterprise Server 10 SP3
  • libgssapi >= 0.6-13.12.1
  • libgssapi-x86 >= 0.6-13.12.1
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.s390x
sles10-sp3.ia64
ZYPP Patch Nr: 7544
SUSE Linux Enterprise Server 10 SP3
  • libgssapi >= 0.6-13.12.1
  • libgssapi-64bit >= 0.6-13.12.1
sles10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sles10-sp3.s390x
sles10-sp3.ia64
ZYPP Patch Nr: 7544
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libgssglue-devel >= 0.1-20.2.1
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sle11-sp1-sdk.x86
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sles11-sp1.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4620
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libgssglue1 >= 0.1-20.2.1
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sle11-sp1-sdk.x86
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1-vmware.x86
sles11-sp1.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
SAT Patch Nr: 4620
openSUSE Leap 42.1
  • libgssglue-devel >= 0.4-5.1
  • libgssglue1 >= 0.4-5.1
Patchnames:
openSUSE Leap 42.1 GA libgssglue-devel
openSUSE Leap 42.2
  • libgssglue-devel >= 0.4-6.4
  • libgssglue1 >= 0.4-6.4
Patchnames:
openSUSE Leap 42.2 GA libgssglue-devel
openSUSE Leap 42.3
  • libgssglue-devel >= 0.4-8.3
  • libgssglue1 >= 0.4-8.3
Patchnames:
openSUSE Leap 42.3 GA libgssglue-devel
openSUSE Tumbleweed
  • libgssglue-devel >= 0.4-5.10
  • libgssglue1 >= 0.4-5.10
  • libgssglue1-32bit >= 0.4-5.10
Patchnames:
openSUSE Tumbleweed GA libgssglue-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 libgssapi Released
SUSE Linux Enterprise Desktop 10 SP4 libgssapi Released
SUSE Linux Enterprise Server 10 SP3 libgssapi Released
SUSE Linux Enterprise Server 10 SP4 libgssapi Released
SUSE Linux Enterprise Server 10 SP4 LTSS libgssapi Released