Upstream information

CVE-2011-2428 at MITRE

Description

Adobe Flash Player before 10.3.183.10 on Windows, Mac OS X, Linux, and Solaris, and before 10.3.186.7 on Android, allows attackers to execute arbitrary code or cause a denial of service (browser crash) via unspecified vectors, related to a "logic error issue."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.3
openSUSE 11.4
  • flash-player >= 10.3.183.10-0.2.1
SUSE Linux Enterprise Desktop 11 SP1
  • flash-player >= 10.3.183.10-0.2.1
sled11-sp1.x86
sled11-sp1.x86-64
SAT Patch Nr: 5184
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • flash-player >= 10.3.183.10-0.5.1
sled10-sp4.x86-64
sled10-sp4.x86
ZYPP Patch Nr: 7763
openSUSE 11.4
  • flash-player >= 10.3.183.10-0.2.1
Patchnames:
flash-player


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP4 flash-player Released
SUSE Linux Enterprise Desktop 11 SP1 flash-player Released