Upstream information

CVE-2011-0311 at MITRE

Description

The class file parser in IBM Java before 1.4.2 SR13 FP9, as used in IBM Runtimes for Java Technology 5.0.0 before SR13 and 6.0.0 before SR10, allows remote authenticated users to cause a denial of service (JVM segmentation fault, and possibly memory consumption or an infinite loop) via a crafted attribute length field in a class file, which triggers a buffer over-read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.5
Vector AV:N/AC:M/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 690583 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.4.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.12-0.2.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.12-0.2.1
Patchnames:
slessp1-java-1_4_2-ibm
SUSE Linux Enterprise Server for SAP Applications 11 SP1
  • java-1_4_2-ibm-sap >= 1.4.2_sr13.9-0.3.1
  • java-1_4_2-ibm-sap-devel >= 1.4.2_sr13.9-0.3.1
Patchnames:
slesapp1-java-1_4_2-ibm-sap
Open Enterprise Server
  • IBMJava2-JRE >= 1.4.2_sr13.9-0.6
  • IBMJava2-SDK >= 1.4.2_sr13.9-0.6
core9.ppc
core9.x86-64
core9.ia64
sles9-nlpos.x86
core9.s390
core9.s390x
core9.x86
sles9-oes.x86
YOU Patch Nr: 12706
SUSE Linux Enterprise Software Development Kit 11 SP1
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.4.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.4.1
sle11-sp1-sdk.s390x
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1.x86-64
SAT Patch Nr: 4481
SUSE Linux Enterprise Software Development Kit 11 SP1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.4.1
sle11-sp1-sdk.s390x
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1.x86-64
SAT Patch Nr: 4481
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.4.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.9-0.4.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.9-0.4.1
sle11-sp1-sdk.s390x
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1.x86-64
SAT Patch Nr: 4481
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.4.1
sle11-sp1-sdk.s390x
sles11-sp1.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1.x86-64
SAT Patch Nr: 4481
SUSE Linux Enterprise Server 10 SP4 for x86
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.9-0.7.1
sles10-sp4.ppc
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.x86-64
ZYPP Patch Nr: 7504
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.7.1
sles10-sp4.ppc
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.x86-64
ZYPP Patch Nr: 7504
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.9-0.7.1
sles10-sp4.ppc
sles10-sp4.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4.x86-64
ZYPP Patch Nr: 7504
SUSE Linux Enterprise for SAP Applications 11 SP1
  • java-1_4_2-ibm-sap >= 1.4.2_sr13.9-0.3.1
  • java-1_4_2-ibm-sap-devel >= 1.4.2_sr13.9-0.3.1
sle11-sap-sp1.x86-64
SAT Patch Nr: 4856
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • java-1_5_0-ibm >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-alsa >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-demo >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-src >= 1.5.0_sr12.4-0.7.1
sles10-sp3.x86-64
sled10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sled10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7388
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
  • java-1_5_0-ibm >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-alsa-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-demo >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-src >= 1.5.0_sr12.4-0.7.1
sles10-sp3.x86-64
sled10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sled10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7388
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • java-1_5_0-ibm >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-alsa-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr12.4-0.7.1
sles10-sp3.x86-64
sled10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sled10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7388
SUSE Linux Enterprise Server 10 SP3
  • java-1_5_0-ibm >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-alsa >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr12.4-0.7.1
sles10-sp3.x86-64
sled10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sled10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7388
SUSE Linux Enterprise Server 10 SP3
  • java-1_5_0-ibm >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-64bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr12.4-0.7.1
sles10-sp3.x86-64
sled10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sled10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7388
SUSE Linux Enterprise Server 10 SP3
  • java-1_5_0-ibm >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr12.4-0.7.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr12.4-0.7.1
sles10-sp3.x86-64
sled10-sp3.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sled10-sp3.x86
sles10-sp3.s390x
ZYPP Patch Nr: 7388
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.9-0.7.1
sle10-sp3-sdk.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ppc
sle10-sp3-sdk.s390x
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sle10-sp3-sdk.x86
sles10-sp3.ia64
ZYPP Patch Nr: 7505
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.7.1
sle10-sp3-sdk.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ppc
sle10-sp3-sdk.s390x
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sle10-sp3-sdk.x86
sles10-sp3.ia64
ZYPP Patch Nr: 7505
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • java-1_4_2-ibm >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.9-0.7.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.9-0.7.1
sle10-sp3-sdk.x86-64
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ppc
sle10-sp3-sdk.s390x
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sle10-sp3-sdk.x86
sles10-sp3.ia64
ZYPP Patch Nr: 7505


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP1 java-1_4_2-ibm Released
SUSE Linux Enterprise Server 10 SP3 java-1_4_2-ibm Released
SUSE Linux Enterprise Server 10 SP4 java-1_4_2-ibm Released
SUSE Linux Enterprise Server 10 SP4 LTSS java-1_4_2-ibm Released
SUSE Linux Enterprise Server 11 SP1 java-1_4_2-ibm Released
SUSE Linux Enterprise Server 11 SP1 LTSS java-1_4_2-ibm Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 java-1_4_2-ibm Released