Upstream information

CVE-2010-4409 at MITRE

Description

Integer overflow in the NumberFormatter::getSymbol (aka numfmt_get_symbol) function in PHP 5.3.3 and earlier allows context-dependent attackers to cause a denial of service (application crash) via an invalid argument.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 657910 [RESOLVED / FIXED], 681195 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • icu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-devel >= 4.0-7.26.15
  • libicu-devel-32bit >= 4.0-7.26.15
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA icu-4.0-7.26.15
SUSE Linux Enterprise Server 11 SP1
  • libicu >= 4.0-7.26.1
  • libicu-32bit >= 4.0-7.26.1
  • libicu-doc >= 4.0-7.26.1
Patchnames:
slessp1-icu
SUSE Linux Enterprise Server 11 SP2
  • libicu >= 4.0-7.26.1
  • libicu-32bit >= 4.0-7.26.1
  • libicu-doc >= 4.0-7.26.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libicu-32bit-4.0-7.26.1
SUSE Linux Enterprise Server 11 SP3
  • libicu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
  • libicu-x86 >= 4.0-7.26.15
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libicu-32bit-4.0-7.26.15
SUSE Linux Enterprise Server 11 SP4
  • icu >= 4.0-7.26.15
  • libicu >= 4.0-7.26.15
  • libicu-32bit >= 4.0-7.26.15
  • libicu-devel >= 4.0-7.26.15
  • libicu-devel-32bit >= 4.0-7.26.15
  • libicu-doc >= 4.0-7.26.15
  • libicu-x86 >= 4.0-7.26.15
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libicu-32bit-4.0-7.26.15
SUSE Linux Enterprise Software Development Kit 11 SP4 GA icu-4.0-7.26.15


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications icu Affected
SUSE Linux Enterprise Desktop 11 SP1 icu Affected
SUSE Linux Enterprise Desktop 11 SP2 icu Affected
SUSE Linux Enterprise Desktop 11 SP3 icu Affected
SUSE Linux Enterprise Desktop 11 SP4 icu Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search icu Affected
SUSE Linux Enterprise Server 11 SP1 icu Affected
SUSE Linux Enterprise Server 11 SP1 LTSS icu Affected
SUSE Linux Enterprise Server 11 SP2 icu Affected
SUSE Linux Enterprise Server 11 SP2 LTSS icu Affected
SUSE Linux Enterprise Server 11 SP3 icu Affected
SUSE Linux Enterprise Server 11 SP3 LTSS icu Affected
SUSE Linux Enterprise Server 11 SP3-LTSS icu Affected
SUSE Linux Enterprise Server 11 SP4 icu Affected
SUSE Linux Enterprise Server 11 SP4 LTSS icu Affected
SUSE Linux Enterprise Server 11 SP4-LTSS icu Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 icu Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 icu Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 icu Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 icu Affected
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 icu Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 icu Affected
SUSE Linux Enterprise Software Development Kit 11 SP2 icu Affected
SUSE Linux Enterprise Software Development Kit 11 SP3 icu Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 icu Affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 08:22:01 2013
CVE page last modified: Tue Nov 29 12:02:17 2022