Upstream information

CVE-2010-2216 at MITRE

Description

Adobe Flash Player before 9.0.280 and 10.x before 10.1.82.76, and Adobe AIR before 2.0.3, allows attackers to execute arbitrary code or cause a denial of service (memory corruption) via unspecified vectors, a different vulnerability than CVE-2010-0209, CVE-2010-2213, and CVE-2010-2214.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 630108 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • flash-player >= 11.2.202.406-1.3
  • flash-player-gnome >= 11.2.202.406-1.3
Patchnames:
SUSE Linux Enterprise Desktop 12 GA flash-player
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 11.2.202.548-111.1
  • flash-player-gnome >= 11.2.202.548-111.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA flash-player
SUSE Linux Enterprise Workstation Extension 12
  • flash-player >= 11.2.202.406-1.3
  • flash-player-gnome >= 11.2.202.406-1.3
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA flash-player
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 11.2.202.548-111.1
  • flash-player-gnome >= 11.2.202.548-111.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA flash-player
SUSE Linux Enterprise Desktop 11 GA
  • acroread_ja >= 9.3.4-0.1.1
sled11.x86
sled11.x86-64
SAT Patch Nr: 3004
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread >= 9.3.4-0.5.1
  • acroread-cmaps >= 9.3.4-0.5.1
  • acroread-fonts-ja >= 9.3.4-0.5.1
  • acroread-fonts-ko >= 9.3.4-0.5.1
  • acroread-fonts-zh_CN >= 9.3.4-0.5.1
  • acroread-fonts-zh_TW >= 9.3.4-0.5.1
sled10-sp3.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 7131
SUSE Linux Enterprise Desktop 11 SP1
  • acroread_ja >= 9.3.4-0.1.1
sled11-sp1.x86
sled11-sp1.x86-64
SAT Patch Nr: 3005
SUSE Linux Enterprise 11 Moblin 2.1
  • flash-player >= 10.1.82.76-0.1.1
SAT Patch Nr: 2898
SUSE Linux Enterprise 11 Moblin 2.0
  • flash-player >= 10.1.82.76-0.1.1
SAT Patch Nr: 2897
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • flash-player >= 9.0.280.0-0.4.1
sled10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7119
openSUSE 11.1
openSUSE 11.2
openSUSE 11.3
  • flash-player >= 10.1.82.76-0.1.1
SUSE Linux Enterprise Desktop 11 SP1
  • flash-player >= 10.1.82.76-0.1.1
sled11-sp1.x86-64
sled11-sp1.x86
SAT Patch Nr: 2901
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread_ja >= 9.3.4-0.4.1
sled10-sp3.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 7132
SUSE Linux Enterprise Desktop 11 GA
  • flash-player >= 10.1.82.76-0.1.1
sled11.x86-64
sled11.x86
SAT Patch Nr: 2900
openSUSE 11.1
openSUSE 11.2
  • acroread >= 9.3.4-0.3.1
  • acroread-cmaps >= 9.3.4-0.3.1
  • acroread-fonts-ja >= 9.3.4-0.3.1
  • acroread-fonts-ko >= 9.3.4-0.3.1
  • acroread-fonts-zh_CN >= 9.3.4-0.3.1
  • acroread-fonts-zh_TW >= 9.3.4-0.3.1
openSUSE 11.3
  • acroread >= 9.3.4-0.2.1
SUSE Linux Enterprise Desktop 11 GA
  • acroread >= 9.3.4-0.6.1
  • acroread-cmaps >= 9.3.4-0.6.1
  • acroread-fonts-ja >= 9.3.4-0.6.1
  • acroread-fonts-ko >= 9.3.4-0.6.1
  • acroread-fonts-zh_CN >= 9.3.4-0.6.1
  • acroread-fonts-zh_TW >= 9.3.4-0.6.1
sled11.x86-64
sled11.x86
SAT Patch Nr: 3008
SUSE Linux Enterprise Desktop 11 SP1
  • acroread >= 9.3.4-0.6.1
  • acroread-cmaps >= 9.3.4-0.6.1
  • acroread-fonts-ja >= 9.3.4-0.6.1
  • acroread-fonts-ko >= 9.3.4-0.6.1
  • acroread-fonts-zh_CN >= 9.3.4-0.6.1
  • acroread-fonts-zh_TW >= 9.3.4-0.6.1
sled11-sp1.x86-64
sled11-sp1.x86
SAT Patch Nr: 3009
SUSE Linux Enterprise 11 Moblin 2.0
  • acroread-debuginfo >= 9.3.4-0.6.1
SAT Patch Nr: 3006
SUSE Linux Enterprise 11 Moblin 2.0
  • acroread >= 9.3.4-0.6.1
SAT Patch Nr: 3006


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 acroread Released
SUSE Linux Enterprise Desktop 10 SP3 flash-player Released
SUSE Linux Enterprise Desktop 11 GA acroread Released
SUSE Linux Enterprise Desktop 11 GA flash-player Released
SUSE Linux Enterprise Desktop 11 SP1 acroread Released
SUSE Linux Enterprise Desktop 11 SP1 flash-player Released