Upstream information

CVE-2009-3881 at MITRE

Description

Sun Java SE 5.0 before Update 22 and 6 before Update 17, and OpenJDK, does not prevent the existence of children of a resurrected ClassLoader, which allows remote attackers to gain privileges via unspecified vectors, related to an "information leak vulnerability," aka Bug Id 6636650.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 554069 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • java-1_6_0-openjdk-debuginfo >= 1.6.2_b16-0.1
  • java-1_6_0-openjdk-debugsource >= 1.6.2_b16-0.1
openSUSE 11.0
  • java-1_6_0-openjdk >= 1.6.2_b16-0.1
  • java-1_6_0-openjdk-demo >= 1.6.2_b16-0.1
  • java-1_6_0-openjdk-devel >= 1.6.2_b16-0.1
  • java-1_6_0-openjdk-javadoc >= 1.6.2_b16-0.1
  • java-1_6_0-openjdk-plugin >= 1.6.2_b16-0.1
  • java-1_6_0-openjdk-src >= 1.6.2_b16-0.1
openSUSE 11.1
  • java-1_6_0-openjdk-debuginfo >= 1.6.2_b16-0.1.1
  • java-1_6_0-openjdk-debugsource >= 1.6.2_b16-0.1.1
openSUSE 11.1
  • java-1_6_0-openjdk >= 1.6.2_b16-0.1.1
  • java-1_6_0-openjdk-demo >= 1.6.2_b16-0.1.1
  • java-1_6_0-openjdk-devel >= 1.6.2_b16-0.1.1
  • java-1_6_0-openjdk-javadoc >= 1.6.2_b16-0.1.1
  • java-1_6_0-openjdk-plugin >= 1.6.2_b16-0.1.1
  • java-1_6_0-openjdk-src >= 1.6.2_b16-0.1.1
openSUSE 11.2
  • java-1_6_0-openjdk-debuginfo >= 1.6.0.0_b16-5.8.1
  • java-1_6_0-openjdk-debugsource >= 1.6.0.0_b16-5.8.1
openSUSE 11.2
  • java-1_6_0-openjdk >= 1.6.0.0_b16-5.8.1
  • java-1_6_0-openjdk-demo >= 1.6.0.0_b16-5.8.1
  • java-1_6_0-openjdk-devel >= 1.6.0.0_b16-5.8.1
  • java-1_6_0-openjdk-javadoc >= 1.6.0.0_b16-5.8.1
  • java-1_6_0-openjdk-plugin >= 1.6.0.0_b16-5.8.1
  • java-1_6_0-openjdk-src >= 1.6.0.0_b16-5.8.1