Upstream information

CVE-2009-3700 at MITRE

Description

Buffer overflow in sgLog.c in squidGuard 1.3 and 1.4 allows remote attackers to cause a denial of service (application hang or loss of blocking functionality) via a long URL with many / (slash) characters, related to "emergency mode."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 550930 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
openSUSE 11.1
  • squidGuard-debuginfo >= 1.3-57.67.1
  • squidGuard-debugsource >= 1.3-57.67.1
openSUSE 11.1
  • squidGuard >= 1.3-57.67.1
openSUSE 11.2
  • squidGuard-debuginfo >= 1.4-2.3.1
  • squidGuard-debugsource >= 1.4-2.3.1
openSUSE 11.2
  • squidGuard >= 1.4-2.3.1
  • squidGuard-doc >= 1.4-2.3.1
openSUSE 11.3
  • squidGuard-debuginfo >= 1.4-7.1.1
  • squidGuard-debugsource >= 1.4-7.1.1
openSUSE 11.3
  • squidGuard >= 1.4-7.1.1
  • squidGuard-doc >= 1.4-7.1.1
openSUSE Leap 42.2
  • squidGuard >= 1.4-4.1
Patchnames:
openSUSE Leap 42.2 GA squidGuard
openSUSE Leap 42.3
  • squidGuard >= 1.4-6.1
Patchnames:
openSUSE Leap 42.3 GA squidGuard
openSUSE Tumbleweed
  • squidGuard >= 1.4-27.7
  • squidGuard-doc >= 1.4-27.7
Patchnames:
openSUSE Tumbleweed GA squidGuard