Upstream information

CVE-2009-2986 at MITRE

Description

Multiple heap-based buffer overflows in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 might allow attackers to execute arbitrary code via unspecified vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 546083 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • acroread >= 8.1.7-0.1
Builds
openSUSE 11.1
  • acroread >= 8.1.7-0.1.1
Builds
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread >= 8.1.7-0.5.1
sled10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 6583
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread_ja >= 8.1.7-0.5.1
sled10-sp3.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 6585
SUSE Linux Enterprise Desktop 11 GA
  • acroread_ja >= 8.1.7-0.1.1
sled11.x86-64
sled11.x86
SAT Patch Nr: 1424
SUSE Linux Enterprise Desktop 11 GA
  • acroread >= 8.1.7-0.1.1
sled11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-debuginfo.x86
SAT Patch Nr: 1425
SUSE Linux Enterprise 11 Moblin 2.0
  • acroread >= 8.1.7-0.1.1
SAT Patch Nr: 1468


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 acroread Released
SUSE Linux Enterprise Desktop 11 GA acroread Released