Upstream information

CVE-2009-1493 at MITRE

Description

The customDictionaryOpen spell method in the JavaScript API in Adobe Reader 9.1, 8.1.4, 7.1.1, and earlier on Linux and UNIX allows remote attackers to cause a denial of service (memory corruption) or execute arbitrary code via a PDF file that triggers a call to this method with a long string in the second argument.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 499097 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 GA
  • acroread >= 8.1.5-0.1.1
sled11.x86
sle11-debuginfo.x86-64
sled11.x86-64
sle11-debuginfo.x86
SAT Patch Nr: 899
openSUSE 11.0
  • acroread >= 8.1.5-0.1
openSUSE 11.1
  • acroread >= 8.1.5-0.1.1
SUSE Linux Enterprise Desktop 11 GA
  • acroread_ja >= 8.1.5-0.1.1
sled11.x86
sled11.x86-64
SAT Patch Nr: 904


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA acroread Released
SUSE Linux Enterprise Desktop 11 SP1 acroread Released
SUSE Linux Enterprise Desktop 11 SP2 acroread Released
SUSE Linux Enterprise Desktop 11 SP3 acroread Released
SUSE Linux Enterprise Desktop 11 SP4 acroread Released