Upstream information

CVE-2009-0186 at MITRE

Description

Integer overflow in libsndfile 1.0.18, as used in Winamp and other products, allows context-dependent attackers to execute arbitrary code via crafted description chunks in a CAF audio file, leading to a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 481769 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libsndfile1 >= 1.0.25-18.75
  • libsndfile1-32bit >= 1.0.25-18.75
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libsndfile1
SUSE Linux Enterprise Desktop 12 SP1
  • libsndfile1 >= 1.0.25-21.1
  • libsndfile1-32bit >= 1.0.25-21.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libsndfile1
SUSE Linux Enterprise Desktop 12 SP2
  • libsndfile1 >= 1.0.25-25.1
  • libsndfile1-32bit >= 1.0.25-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libsndfile1
SUSE Linux Enterprise Desktop 12 SP3
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libsndfile1
SUSE Linux Enterprise Module for Basesystem 15
  • libsndfile-devel >= 1.0.28-3.24
  • libsndfile1 >= 1.0.28-3.24
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libsndfile-devel
SUSE Linux Enterprise Server 11
  • libsndfile >= 1.0.17-172.13.1
  • libsndfile-32bit >= 1.0.17-172.13.1
  • libsndfile-x86 >= 1.0.17-172.14.1
Patchnames:
slessp0-libsndfile
SUSE Linux Enterprise Server 11 SP1
  • libsndfile >= 1.0.20-2.1.46
  • libsndfile-32bit >= 1.0.20-2.1.46
  • libsndfile-x86 >= 1.0.20-2.1.46
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libsndfile
SUSE Linux Enterprise Server 11 SP2
  • libsndfile >= 1.0.20-2.4.1
  • libsndfile-32bit >= 1.0.20-2.4.1
  • libsndfile-x86 >= 1.0.20-2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libsndfile
SUSE Linux Enterprise Server 11 SP3
  • libsndfile >= 1.0.20-2.4.1
  • libsndfile-32bit >= 1.0.20-2.4.1
  • libsndfile-x86 >= 1.0.20-2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libsndfile
SUSE Linux Enterprise Server 11 SP4
  • libsndfile >= 1.0.20-2.6.5
  • libsndfile-32bit >= 1.0.20-2.6.5
  • libsndfile-x86 >= 1.0.20-2.6.5
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libsndfile
SUSE Linux Enterprise Server 12
  • libsndfile1 >= 1.0.25-18.75
  • libsndfile1-32bit >= 1.0.25-18.75
Patchnames:
SUSE Linux Enterprise Server 12 GA libsndfile1
SUSE Linux Enterprise Server 12 SP1
  • libsndfile1 >= 1.0.25-21.1
  • libsndfile1-32bit >= 1.0.25-21.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libsndfile1
SUSE Linux Enterprise Server 12 SP2
  • libsndfile1 >= 1.0.25-25.1
  • libsndfile1-32bit >= 1.0.25-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libsndfile1
SUSE Linux Enterprise Server 12 SP3
  • libsndfile1 >= 1.0.25-35.1
  • libsndfile1-32bit >= 1.0.25-35.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libsndfile1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsndfile1 >= 1.0.25-25.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libsndfile1
SUSE Linux Enterprise Server for SAP Applications 11
  • libsndfile >= 1.0.17-172.13.1
  • libsndfile-32bit >= 1.0.17-172.13.1
  • libsndfile-x86 >= 1.0.17-172.14.1
Patchnames:
slessp0-libsndfile
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libsndfile-devel >= 1.0.20-2.6.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libsndfile-devel
SUSE Linux Enterprise Software Development Kit 12
  • libsndfile-devel >= 1.0.25-18.75
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libsndfile-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsndfile-devel >= 1.0.25-21.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libsndfile-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libsndfile-devel >= 1.0.25-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libsndfile-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsndfile-devel >= 1.0.25-35.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libsndfile-devel
openSUSE 11.0
  • libsndfile-debuginfo >= 1.0.17-141.2
  • libsndfile-debugsource >= 1.0.17-141.2
openSUSE 11.0
  • libsndfile >= 1.0.17-141.2
  • libsndfile-32bit >= 1.0.17-141.2
  • libsndfile-64bit >= 1.0.17-141.2
  • libsndfile-devel >= 1.0.17-141.2
  • libsndfile-octave >= 1.0.17-141.2
  • libsndfile-progs >= 1.0.17-141.2
openSUSE 11.1
  • libsndfile-debuginfo >= 1.0.17-171.8.1
  • libsndfile-debugsource >= 1.0.17-171.8.1
openSUSE 11.1
  • libsndfile >= 1.0.17-171.8.1
  • libsndfile-32bit >= 1.0.17-171.8.1
  • libsndfile-64bit >= 1.0.17-171.8.1
  • libsndfile-devel >= 1.0.17-171.8.1
  • libsndfile-octave >= 1.0.17-171.8.1
  • libsndfile-progs >= 1.0.17-171.8.1
SUSE Linux Enterprise SDK 10 SP2
  • libsndfile-devel >= 1.0.12-13.10
sles10-sp2.x86
sles10-sp2.ppc
sle10-sp2-sdk.ia64
sle10-sp2-sdk.s390x
sle10-sp2-sdk.x86
sles10-sp2.ia64
sles10-sp2.x86-64
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.s390x
sle10-sp2-sdk.x86-64
sled10-sp2.x86
ZYPP Patch Nr: 6040
SUSE Linux Enterprise SDK 11 GA
  • libsndfile-devel >= 1.0.17-172.13.1
sles11.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.x86
sles11.s390x
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sle11-sdk.ia64
sles11.x86
sled11.x86-64
sles11.x86-64
sle11-debuginfo.ia64
sles11.ppc
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-sdk.x86-64
sle11-sdk.s390x
SAT Patch Nr: 637
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • libsndfile >= 1.0.17-172.13.1
sles11.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.x86
sles11.s390x
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sle11-sdk.ia64
sles11.x86
sled11.x86-64
sles11.x86-64
sle11-debuginfo.ia64
sles11.ppc
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-sdk.x86-64
sle11-sdk.s390x
SAT Patch Nr: 637
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • libsndfile >= 1.0.17-172.13.1
  • libsndfile-32bit >= 1.0.17-172.13.1
sles11.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.x86
sles11.s390x
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sle11-sdk.ia64
sles11.x86
sled11.x86-64
sles11.x86-64
sle11-debuginfo.ia64
sles11.ppc
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-sdk.x86-64
sle11-sdk.s390x
SAT Patch Nr: 637
SUSE Linux Enterprise Server 11 GA
  • libsndfile >= 1.0.17-172.13.1
  • libsndfile-x86 >= 1.0.17-172.13.1
sles11.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.x86
sles11.s390x
sle11-debuginfo.s390x
sle11-sdk.x86
sled11.x86
sle11-sdk.ia64
sles11.x86
sled11.x86-64
sles11.x86-64
sle11-debuginfo.ia64
sles11.ppc
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-sdk.x86-64
sle11-sdk.s390x
SAT Patch Nr: 637
openSUSE Leap 15.0
  • libsndfile1 >= 1.0.28-lp150.2.5
Patchnames:
openSUSE Leap 15.0 GA libsndfile1
openSUSE Leap 42.1
  • libsndfile-devel >= 1.0.25-20.1
  • libsndfile1 >= 1.0.25-20.1
  • libsndfile1-32bit >= 1.0.25-20.1
Patchnames:
openSUSE Leap 42.1 GA libsndfile-devel
openSUSE Leap 42.2
  • libsndfile-devel >= 1.0.25-25.1
  • libsndfile1 >= 1.0.25-25.1
  • libsndfile1-32bit >= 1.0.25-25.1
Patchnames:
openSUSE Leap 42.2 GA libsndfile-devel
openSUSE Leap 42.3
  • libsndfile-devel >= 1.0.25-29.1
  • libsndfile1 >= 1.0.25-29.1
  • libsndfile1-32bit >= 1.0.25-29.1
Patchnames:
openSUSE Leap 42.3 GA libsndfile-devel
openSUSE Tumbleweed
  • libsndfile-devel >= 1.0.26-2.4
  • libsndfile-progs >= 1.0.26-2.4
  • libsndfile1 >= 1.0.26-2.4
  • libsndfile1-32bit >= 1.0.26-2.4
Patchnames:
openSUSE Tumbleweed GA libsndfile-devel
openSUSE Tumbleweed GA libsndfile-progs


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA libsndfile Released
SUSE Linux Enterprise SDK 11 GA libsndfile Released
SUSE Linux Enterprise Server 11 GA libsndfile Released