Upstream information

CVE-2008-3187 at MITRE

Description

zypp-refresh-patches in zypper in SUSE openSUSE 10.2, 10.3, and 11.0 does not ask the user before accepting repository keys, which allows remote repositories to cause a denial of service (package data corruption) via a spoofed key.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 398530 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • libzypp >= 4.26.7-0.1
  • libzypp-devel >= 4.26.7-0.1
  • yast2-pkg-bindings >= 2.16.40-0.1
  • yast2-pkg-bindings-devel-doc >= 2.16.40-0.1
  • zypper >= 0.11.9-0.1