Upstream information

CVE-2008-0386 at MITRE

Description

Xdg-utils 1.0.2 and earlier allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a URL argument to (1) xdg-open or (2) xdg-email.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 355061 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • xdg-utils >= 1.0.2-36.18
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA xdg-utils
SUSE Linux Enterprise Server 11 SP2
  • xdg-utils >= 1.0.2-36.18
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA xdg-utils
SUSE Linux Enterprise Server 11 SP3
  • xdg-utils >= 1.0.2-36.18
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA xdg-utils
SUSE Linux Enterprise Server 11 SP4
  • xdg-utils >= 1.0.2-36.18
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA xdg-utils