Upstream information

CVE-2008-0008 at MITRE

Description

The pa_drop_root function in PulseAudio 0.9.8, and a certain 0.9.9 build, does not check return values from (1) setresuid, (2) setreuid, (3) setuid, and (4) seteuid calls when attempting to drop privileges, which might allow local users to gain privileges by causing those calls to fail via attacks such as resource exhaustion.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 347822 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libpulse-browse0 >= 0.9.21-1.5.26
  • libpulse-mainloop-glib0 >= 0.9.21-1.5.26
  • libpulse0 >= 0.9.21-1.5.26
  • libpulse0-32bit >= 0.9.21-1.5.26
  • libpulse0-x86 >= 0.9.21-1.5.26
  • pulseaudio >= 0.9.21-1.5.26
  • pulseaudio-esound-compat >= 0.9.21-1.5.26
  • pulseaudio-gdm-hooks >= 0.9.21-1.5.26
  • pulseaudio-lang >= 0.9.21-1.5.26
  • pulseaudio-module-x11 >= 0.9.21-1.5.26
  • pulseaudio-module-zeroconf >= 0.9.21-1.5.26
  • pulseaudio-utils >= 0.9.21-1.5.26
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libpulse-browse0
SUSE Linux Enterprise Server 11 SP2
  • libpulse-browse0 >= 0.9.23-0.7.128
  • libpulse-mainloop-glib0 >= 0.9.23-0.7.128
  • libpulse0 >= 0.9.23-0.7.128
  • libpulse0-32bit >= 0.9.23-0.7.128
  • libpulse0-x86 >= 0.9.23-0.7.128
  • pulseaudio >= 0.9.23-0.7.128
  • pulseaudio-esound-compat >= 0.9.23-0.7.128
  • pulseaudio-gdm-hooks >= 0.9.23-0.7.128
  • pulseaudio-lang >= 0.9.23-0.7.128
  • pulseaudio-module-x11 >= 0.9.23-0.7.128
  • pulseaudio-module-zeroconf >= 0.9.23-0.7.128
  • pulseaudio-utils >= 0.9.23-0.7.128
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libpulse-browse0
SUSE Linux Enterprise Server 11 SP3
  • libpulse-browse0 >= 0.9.23-0.7.128
  • libpulse-mainloop-glib0 >= 0.9.23-0.7.128
  • libpulse0 >= 0.9.23-0.7.128
  • libpulse0-32bit >= 0.9.23-0.7.128
  • libpulse0-x86 >= 0.9.23-0.7.128
  • pulseaudio >= 0.9.23-0.7.128
  • pulseaudio-esound-compat >= 0.9.23-0.7.128
  • pulseaudio-gdm-hooks >= 0.9.23-0.7.128
  • pulseaudio-lang >= 0.9.23-0.7.128
  • pulseaudio-module-x11 >= 0.9.23-0.7.128
  • pulseaudio-module-zeroconf >= 0.9.23-0.7.128
  • pulseaudio-utils >= 0.9.23-0.7.128
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libpulse-browse0
SUSE Linux Enterprise Server 11 SP4
  • libpulse-browse0 >= 0.9.23-0.17.1
  • libpulse-mainloop-glib0 >= 0.9.23-0.17.1
  • libpulse-mainloop-glib0-32bit >= 0.9.23-0.17.1
  • libpulse-mainloop-glib0-x86 >= 0.9.23-0.17.1
  • libpulse0 >= 0.9.23-0.17.1
  • libpulse0-32bit >= 0.9.23-0.17.1
  • libpulse0-x86 >= 0.9.23-0.17.1
  • pulseaudio >= 0.9.23-0.17.1
  • pulseaudio-esound-compat >= 0.9.23-0.17.1
  • pulseaudio-gdm-hooks >= 0.9.23-0.17.1
  • pulseaudio-lang >= 0.9.23-0.17.1
  • pulseaudio-module-x11 >= 0.9.23-0.17.1
  • pulseaudio-module-zeroconf >= 0.9.23-0.17.1
  • pulseaudio-utils >= 0.9.23-0.17.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libpulse-browse0
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpulse-devel >= 0.9.23-0.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libpulse-devel