Upstream information

CVE-2007-5707 at MITRE

Description

OpenLDAP before 2.3.39 allows remote attackers to cause a denial of service (slapd crash) via an LDAP request with a malformed objectClasses attribute. NOTE: this has been reported as a double free, but the reports are inconsistent.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entry: 339076 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.1
  • openldap2 >= 2.3.19-18.15
  • openldap2-back-meta >= 2.3.19-18.15
  • openldap2-back-perl >= 2.3.19-18.15
  • openldap2-devel >= 2.3.19-18.14
  • openldap2-devel-32bit >= 2.3.19-18.14
  • openldap2-devel-64bit >= 2.3.19-18.14