Upstream information

CVE-2007-4575 at MITRE

Description

HSQLDB before 1.8.0.9, as used in OpenOffice.org (OOo) 2 before 2.3.1, allows user-assisted remote attackers to execute arbitrary Java code via crafted database documents, related to "exposing static java methods."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 343765 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • OpenOffice_org >= 2.0.0-1.15
  • OpenOffice_org-af >= 2.0.0-1.15
  • OpenOffice_org-ar >= 2.0.0-1.15
  • OpenOffice_org-be-BY >= 2.0.0-1.15
  • OpenOffice_org-bg >= 2.0.0-1.15
  • OpenOffice_org-ca >= 2.0.0-1.15
  • OpenOffice_org-cs >= 2.0.0-1.15
  • OpenOffice_org-cy >= 2.0.0-1.15
  • OpenOffice_org-da >= 2.0.0-1.15
  • OpenOffice_org-de >= 2.0.0-1.15
  • OpenOffice_org-el >= 2.0.0-1.15
  • OpenOffice_org-en-GB >= 2.0.0-1.15
  • OpenOffice_org-es >= 2.0.0-1.15
  • OpenOffice_org-et >= 2.0.0-1.15
  • OpenOffice_org-fi >= 2.0.0-1.15
  • OpenOffice_org-fr >= 2.0.0-1.15
  • OpenOffice_org-galleries >= 2.0.0-1.15
  • OpenOffice_org-gnome >= 2.0.0-1.15
  • OpenOffice_org-gu-IN >= 2.0.0-1.15
  • OpenOffice_org-hr >= 2.0.0-1.15
  • OpenOffice_org-hu >= 2.0.0-1.15
  • OpenOffice_org-hunspell >= 2.0.0-1.15
  • OpenOffice_org-it >= 2.0.0-1.15
  • OpenOffice_org-ja >= 2.0.0-1.15
  • OpenOffice_org-kde >= 2.0.0-1.15
  • OpenOffice_org-ko >= 2.0.0-1.15
  • OpenOffice_org-mono >= 2.0.0-1.15
  • OpenOffice_org-nb >= 2.0.0-1.15
  • OpenOffice_org-nl >= 2.0.0-1.15
  • OpenOffice_org-nn >= 2.0.0-1.15
  • OpenOffice_org-officebean >= 2.0.0-1.15
  • OpenOffice_org-pa-IN >= 2.0.0-1.15
  • OpenOffice_org-pl >= 2.0.0-1.15
  • OpenOffice_org-pt >= 2.0.0-1.15
  • OpenOffice_org-pt-BR >= 2.0.0-1.15
  • OpenOffice_org-ru >= 2.0.0-1.15
  • OpenOffice_org-sk >= 2.0.0-1.15
  • OpenOffice_org-sl >= 2.0.0-1.15
  • OpenOffice_org-sv >= 2.0.0-1.15
  • OpenOffice_org-tr >= 2.0.0-1.15
  • OpenOffice_org-vi >= 2.0.0-1.15
  • OpenOffice_org-xh >= 2.0.0-1.15
  • OpenOffice_org-zh-CN >= 2.0.0-1.15
  • OpenOffice_org-zh-TW >= 2.0.0-1.15
  • OpenOffice_org-zu >= 2.0.0-1.15
SUSE LINUX 10.1
  • OpenOffice_org >= 2.0.4-38.7
  • OpenOffice_org-af >= 2.0.4-38.7
  • OpenOffice_org-ar >= 2.0.4-38.7
  • OpenOffice_org-be-BY >= 2.0.4-38.7
  • OpenOffice_org-bg >= 2.0.4-38.7
  • OpenOffice_org-ca >= 2.0.4-38.7
  • OpenOffice_org-cs >= 2.0.4-38.7
  • OpenOffice_org-cy >= 2.0.4-38.7
  • OpenOffice_org-da >= 2.0.4-38.7
  • OpenOffice_org-de >= 2.0.4-38.7
  • OpenOffice_org-el >= 2.0.4-38.7
  • OpenOffice_org-en-GB >= 2.0.4-38.7
  • OpenOffice_org-es >= 2.0.4-38.7
  • OpenOffice_org-et >= 2.0.4-38.7
  • OpenOffice_org-fi >= 2.0.4-38.7
  • OpenOffice_org-fr >= 2.0.4-38.7
  • OpenOffice_org-galleries >= 2.0.4-38.7
  • OpenOffice_org-gnome >= 2.0.4-38.7
  • OpenOffice_org-gu-IN >= 2.0.4-38.7
  • OpenOffice_org-hi-IN >= 2.0.4-38.7
  • OpenOffice_org-hr >= 2.0.4-38.7
  • OpenOffice_org-hu >= 2.0.4-38.7
  • OpenOffice_org-it >= 2.0.4-38.7
  • OpenOffice_org-ja >= 2.0.4-38.7
  • OpenOffice_org-kde >= 2.0.4-38.7
  • OpenOffice_org-km >= 2.0.4-38.7
  • OpenOffice_org-ko >= 2.0.4-38.7
  • OpenOffice_org-lt >= 2.0.4-38.7
  • OpenOffice_org-mk >= 2.0.4-38.7
  • OpenOffice_org-mono >= 2.0.4-38.7
  • OpenOffice_org-nb >= 2.0.4-38.7
  • OpenOffice_org-nl >= 2.0.4-38.7
  • OpenOffice_org-nn >= 2.0.4-38.7
  • OpenOffice_org-officebean >= 2.0.4-38.7
  • OpenOffice_org-pa-IN >= 2.0.4-38.7
  • OpenOffice_org-pl >= 2.0.4-38.7
  • OpenOffice_org-pt >= 2.0.4-38.7
  • OpenOffice_org-pt-BR >= 2.0.4-38.7
  • OpenOffice_org-ru >= 2.0.4-38.7
  • OpenOffice_org-rw >= 2.0.4-38.7
  • OpenOffice_org-sk >= 2.0.4-38.7
  • OpenOffice_org-sl >= 2.0.4-38.7
  • OpenOffice_org-sr-CS >= 2.0.4-38.7
  • OpenOffice_org-st >= 2.0.4-38.7
  • OpenOffice_org-sv >= 2.0.4-38.7
  • OpenOffice_org-tr >= 2.0.4-38.7
  • OpenOffice_org-ts >= 2.0.4-38.7
  • OpenOffice_org-vi >= 2.0.4-38.7
  • OpenOffice_org-xh >= 2.0.4-38.7
  • OpenOffice_org-zh-CN >= 2.0.4-38.7
  • OpenOffice_org-zh-TW >= 2.0.4-38.7
  • OpenOffice_org-zu >= 2.0.4-38.7