Upstream information

CVE-2007-1995 at MITRE

Description

bgpd/bgp_attr.c in Quagga 0.98.6 and earlier, and 0.99.6 and earlier 0.99 versions, does not validate length values in the MP_REACH_NLRI and MP_UNREACH_NLRI attributes, which allows remote attackers to cause a denial of service (daemon crash or exit) via crafted UPDATE messages that trigger an assertion error or out of bounds read.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.3
Vector AV:N/AC:M/Au:S/C:N/I:N/A:C
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entry: 266100 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • quagga >= 0.99.15-0.1.55
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA quagga
SUSE Linux Enterprise Server 11 SP2
  • quagga >= 0.99.15-0.6.2
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA quagga
SUSE Linux Enterprise Server 11 SP3
  • quagga >= 0.99.15-0.12.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA quagga
SUSE Linux Enterprise Server 11 SP4
  • quagga >= 0.99.15-0.14.11
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA quagga
SUSE Linux Enterprise Software Development Kit 11 SP4
  • quagga >= 0.99.15-0.14.11
  • quagga-devel >= 0.99.15-0.14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA quagga
SuSE Linux Enterprise Server 8 for IBM zSeries
  • quagga >= 0.97.3-7.1
ul1.s390
sles10.x86
core9.s390
core9.x86
sles10.s390x
ZYPP Patch Nr: 3230
Open Enterprise Server
  • quagga >= 0.96.4-31.19
ul1.s390
sles10.x86
core9.s390
core9.x86
sles10.s390x
ZYPP Patch Nr: 3230
SUSE LINUX 10.0
  • quagga >= 0.98.4-2.6
  • quagga-devel >= 0.98.4-2.6
SUSE LINUX 10.1
  • quagga >= 0.98.5-17.9.3
  • quagga-devel >= 0.98.5-17.9.3