Upstream information

CVE-2007-1858 at MITRE

Description

The default SSL cipher configuration in Apache Tomcat 4.1.28 through 4.1.31, 5.0.0 through 5.0.30, and 5.5.0 through 5.5.17 uses certain insecure ciphers, including the anonymous cipher, which allows remote attackers to obtain sensitive information or have other, unspecified impacts.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 274242 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
  • jakarta-tomcat >= 5.0.19-29.13
core9.s390
sles9-oes.x86
YOU Patch Nr: 12116
Open Enterprise Server
  • apache-jakarta-tomcat-connectors >= 5.0.19-29.13
  • apache2-jakarta-tomcat-connectors >= 5.0.19-29.13
  • jakarta-tomcat >= 5.0.19-29.13
  • jakarta-tomcat-doc >= 5.0.19-29.13
  • jakarta-tomcat-examples >= 5.0.19-29.13
core9.s390
sles9-oes.x86
YOU Patch Nr: 12116
SUSE LINUX 10.1
  • tomcat5 >= 5.0.30-27.26
  • tomcat5-admin-webapps >= 5.0.30-27.26
  • tomcat5-webapps >= 5.0.30-27.26