Upstream information

CVE-2007-1383 at MITRE

Description

Integer overflow in the 16 bit variable reference counter in PHP 4 allows context-dependent attackers to execute arbitrary code by overflowing this counter, which causes the same variable to be destroyed twice, a related issue to CVE-2007-1286.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 250125 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-526
  • mod_php4-core >= 4.2.2-526
  • mod_php4-devel >= 4.2.2-526
  • mod_php4-servlet >= 4.2.2-526
ul1.s390
slrs8.x86
YOU Patch Nr: 11513
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.37
  • mod_php4-apache2 >= 4.3.10-14.37
  • mod_php4-core >= 4.3.10-14.37
  • mod_php4-servlet >= 4.3.10-14.37
  • php4 >= 4.3.10-14.37
  • php4-32bit >= 9.3-7.16
  • php4-bcmath >= 4.3.10-14.37
  • php4-bz2 >= 4.3.10-14.37
  • php4-calendar >= 4.3.10-14.37
  • php4-ctype >= 4.3.10-14.37
  • php4-curl >= 4.3.10-14.37
  • php4-dbase >= 4.3.10-14.37
  • php4-dbx >= 4.3.10-14.37
  • php4-devel >= 4.3.10-14.37
  • php4-domxml >= 4.3.10-14.37
  • php4-exif >= 4.3.10-14.37
  • php4-fastcgi >= 4.3.10-14.37
  • php4-filepro >= 4.3.10-14.37
  • php4-ftp >= 4.3.10-14.37
  • php4-gd >= 4.3.10-14.37
  • php4-gettext >= 4.3.10-14.37
  • php4-gmp >= 4.3.10-14.37
  • php4-iconv >= 4.3.10-14.37
  • php4-imap >= 4.3.10-14.37
  • php4-ldap >= 4.3.10-14.37
  • php4-mbstring >= 4.3.10-14.37
  • php4-mcal >= 4.3.10-14.37
  • php4-mcrypt >= 4.3.10-14.37
  • php4-mhash >= 4.3.10-14.37
  • php4-mime_magic >= 4.3.10-14.37
  • php4-mysql >= 4.3.10-14.37
  • php4-pear >= 4.3.10-14.37
  • php4-pgsql >= 4.3.10-14.37
  • php4-qtdom >= 4.3.10-14.37
  • php4-recode >= 4.3.10-14.37
  • php4-servlet >= 4.3.10-14.37
  • php4-session >= 4.3.10-14.37
  • php4-shmop >= 4.3.10-14.37
  • php4-snmp >= 4.3.10-14.37
  • php4-sockets >= 4.3.10-14.37
  • php4-swf >= 4.3.10-14.37
  • php4-sysvsem >= 4.3.10-14.37
  • php4-sysvshm >= 4.3.10-14.37
  • php4-unixODBC >= 4.3.10-14.37
  • php4-wddx >= 4.3.10-14.37
  • php4-xslt >= 4.3.10-14.37
  • php4-yp >= 4.3.10-14.37
  • php4-zlib >= 4.3.10-14.37
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.77
  • apache2-mod_php4 >= 4.3.4-43.77
  • mod_php4 >= 4.3.4-43.77
  • mod_php4-apache2 >= 4.3.4-43.77
  • mod_php4-core >= 4.3.4-43.77
  • mod_php4-servlet >= 4.3.4-43.77
  • php4 >= 4.3.4-43.77
  • php4-bcmath >= 4.3.4-43.77
  • php4-bz2 >= 4.3.4-43.77
  • php4-calendar >= 4.3.4-43.77
  • php4-ctype >= 4.3.4-43.77
  • php4-curl >= 4.3.4-43.77
  • php4-dba >= 4.3.4-43.77
  • php4-dbase >= 4.3.4-43.77
  • php4-devel >= 4.3.4-43.77
  • php4-domxml >= 4.3.4-43.77
  • php4-exif >= 4.3.4-43.77
  • php4-fastcgi >= 4.3.4-43.77
  • php4-filepro >= 4.3.4-43.77
  • php4-ftp >= 4.3.4-43.77
  • php4-gd >= 4.3.4-43.77
  • php4-gettext >= 4.3.4-43.77
  • php4-gmp >= 4.3.4-43.77
  • php4-iconv >= 4.3.4-43.77
  • php4-imap >= 4.3.4-43.77
  • php4-ldap >= 4.3.4-43.77
  • php4-mbstring >= 4.3.4-43.77
  • php4-mcal >= 4.3.4-43.77
  • php4-mcrypt >= 4.3.4-43.77
  • php4-mhash >= 4.3.4-43.77
  • php4-mime_magic >= 4.3.4-43.77
  • php4-mysql >= 4.3.4-43.77
  • php4-pear >= 4.3.4-43.77
  • php4-pgsql >= 4.3.4-43.77
  • php4-qtdom >= 4.3.4-43.77
  • php4-readline >= 4.3.4-43.77
  • php4-recode >= 4.3.4-43.77
  • php4-servlet >= 4.3.4-43.77
  • php4-session >= 4.3.4-43.77
  • php4-shmop >= 4.3.4-43.77
  • php4-snmp >= 4.3.4-43.77
  • php4-sockets >= 4.3.4-43.77
  • php4-swf >= 4.3.4-43.77
  • php4-sysvsem >= 4.3.4-43.77
  • php4-sysvshm >= 4.3.4-43.77
  • php4-unixODBC >= 4.3.4-43.77
  • php4-wddx >= 4.3.4-43.77
  • php4-xslt >= 4.3.4-43.77
  • php4-yp >= 4.3.4-43.77
  • php4-zlib >= 4.3.4-43.77
core9.s390
core9.x86
YOU Patch Nr: 11514
SUSE LINUX 10.0
  • apache2-mod_php4 >= 4.4.0-6.27
  • mod_php4-apache2 >= 4.4.0-6.27
  • mod_php4-core >= 4.4.0-6.27
  • mod_php4-servlet >= 4.4.0-6.27
  • php4 >= 4.4.0-6.27
  • php4-32bit >= 4.4.0-6.27
  • php4-64bit >= 4.4.0-6.27
  • php4-bcmath >= 4.4.0-6.27
  • php4-bz2 >= 4.4.0-6.27
  • php4-calendar >= 4.4.0-6.27
  • php4-ctype >= 4.4.0-6.27
  • php4-curl >= 4.4.0-6.27
  • php4-dbase >= 4.4.0-6.27
  • php4-dbx >= 4.4.0-6.27
  • php4-devel >= 4.4.0-6.27
  • php4-domxml >= 4.4.0-6.27
  • php4-exif >= 4.4.0-6.27
  • php4-fastcgi >= 4.4.0-6.27
  • php4-filepro >= 4.4.0-6.27
  • php4-ftp >= 4.4.0-6.27
  • php4-gd >= 4.4.0-6.27
  • php4-gettext >= 4.4.0-6.27
  • php4-gmp >= 4.4.0-6.27
  • php4-iconv >= 4.4.0-6.27
  • php4-imap >= 4.4.0-6.27
  • php4-ldap >= 4.4.0-6.27
  • php4-mbstring >= 4.4.0-6.27
  • php4-mcal >= 4.4.0-6.27
  • php4-mcrypt >= 4.4.0-6.27
  • php4-mhash >= 4.4.0-6.27
  • php4-mime_magic >= 4.4.0-6.27
  • php4-mysql >= 4.4.0-6.27
  • php4-pear >= 4.4.0-6.27
  • php4-pgsql >= 4.4.0-6.27
  • php4-qtdom >= 4.4.0-6.27
  • php4-recode >= 4.4.0-6.27
  • php4-servlet >= 4.4.0-6.27
  • php4-session >= 4.4.0-6.27
  • php4-shmop >= 4.4.0-6.27
  • php4-snmp >= 4.4.0-6.27
  • php4-sockets >= 4.4.0-6.27
  • php4-swf >= 4.4.0-6.27
  • php4-sysvsem >= 4.4.0-6.27
  • php4-sysvshm >= 4.4.0-6.27
  • php4-unixODBC >= 4.4.0-6.27
  • php4-wddx >= 4.4.0-6.27
  • php4-xslt >= 4.4.0-6.27
  • php4-yp >= 4.4.0-6.27
  • php4-zlib >= 4.4.0-6.27