Upstream information

CVE-2007-0002 at MITRE

Description

Multiple heap-based buffer overflows in WordPerfect Document importer/exporter (libwpd) before 0.8.9 allow user-assisted remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a crafted WordPerfect file in which values to loop counters are not properly handled in the (1) WP3TablesGroup::_readContents and (2) WP5DefinitionGroup_DefineTablesSubGroup::WP5DefinitionGroup_DefineTablesSubGroup functions. NOTE: the integer overflow has been split into CVE-2007-1466.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 233981 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwpd-0_8-8 >= 0.8.14-4.33
  • libwpd-devel >= 0.8.14-4.33
  • libwpd-devel-doc >= 0.8.14-4.33
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libwpd-0_8-8-0.8.14-4.33
openSUSE Tumbleweed
  • libwpd-0_10-10 >= 0.10.3-2.3
  • libwpd-devel >= 0.10.3-2.3
  • libwpd-devel-doc >= 0.10.3-2.3
  • libwpd-tools >= 0.10.3-2.3
Patchnames:
openSUSE Tumbleweed GA libwpd-0_10-10-0.10.3-2.3


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 01:42:48 2013
CVE page last modified: Wed Jan 18 11:42:49 2023