Upstream information

CVE-2006-5601 at MITRE

Description

Stack-based buffer overflow in the eap_do_notify function in eap.c in xsupplicant before 1.2.6, and possibly other versions, allows remote authenticated users to execute arbitrary code via unspecified vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9
Vector AV:N/AC:L/Au:S/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 208975 [CLOSED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • xsupplicant >= 1.2.8-16.1
SUSE LINUX 10.1
  • xsupplicant >= 1.2.8-14.5
SUSE LINUX 9.3
  • xsupplicant >= 1.2.8-14.2
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • xsupplicant >= 1.2.8-14.2
sles10.s390x
core9.s390
sles9-oes.x86
sles10.x86
ZYPP Patch Nr: 2455