Upstream information

CVE-2006-1991 at MITRE

Description

The substr_compare function in string.c in PHP 5.1.2 allows context-dependent attackers to cause a denial of service (memory access violation) via an out-of-bounds offset argument.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 169038 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.58
  • apache2-mod_php4 >= 4.3.4-43.58
  • mod_php4-core >= 4.3.4-43.58
  • mod_php4-servlet >= 4.3.4-43.58
  • php4 >= 4.3.4-43.58
  • php4-devel >= 4.3.4-43.58
  • php4-exif >= 4.3.4-43.58
  • php4-fastcgi >= 4.3.4-43.58
  • php4-gd >= 4.3.4-43.58
  • php4-imap >= 4.3.4-43.58
  • php4-mbstring >= 4.3.4-43.58
  • php4-mysql >= 4.3.4-43.58
  • php4-pear >= 4.3.4-43.58
  • php4-recode >= 4.3.4-43.58
  • php4-servlet >= 4.3.4-43.58
  • php4-session >= 4.3.4-43.58
  • php4-sysvshm >= 4.3.4-43.58
Builds
YOU Patch Nr: 11051
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.23
  • php5 >= 5.0.3-14.23
  • php5-devel >= 5.0.3-14.23
  • php5-exif >= 5.0.3-14.23
  • php5-fastcgi >= 5.0.3-14.23
  • php5-gd >= 5.0.3-14.23
  • php5-mbstring >= 5.0.3-14.23
  • php5-mysqli >= 5.0.3-14.23
  • php5-pear >= 5.0.3-14.23
  • php5-sysvmsg >= 5.0.3-14.23
  • php5-sysvshm >= 5.0.3-14.23
SUSE LINUX 10.1
  • apache2-mod_php5 >= 5.1.2-29.4
  • php5 >= 5.1.2-29.4
  • php5-gd >= 5.1.2-29.4
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.23
  • mod_php4-servlet >= 4.3.10-14.23
  • php4 >= 4.3.10-14.23
  • php4-32bit >= 9.3-7.10
  • php4-devel >= 4.3.10-14.23
  • php4-exif >= 4.3.10-14.23
  • php4-fastcgi >= 4.3.10-14.23
  • php4-gd >= 4.3.10-14.23
  • php4-mbstring >= 4.3.10-14.23
  • php4-pear >= 4.3.10-14.23
  • php4-session >= 4.3.10-14.23
  • php4-sysvshm >= 4.3.10-14.23
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • php5-suhosin >= 5.1.2-29.35
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2875
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.13
  • php5 >= 5.0.4-9.13
  • php5-exif >= 5.0.4-9.13
  • php5-fastcgi >= 5.0.4-9.13
  • php5-gd >= 5.0.4-9.13
  • php5-mbstring >= 5.0.4-9.13
  • php5-mysqli >= 5.0.4-9.13
  • php5-pear >= 5.0.4-9.13
  • php5-snmp >= 5.0.4-9.13
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-506
  • mod_php4-core >= 4.2.2-506
  • mod_php4-devel >= 4.2.2-506
  • mod_php4-servlet >= 4.2.2-506
Builds
YOU Patch Nr: 11042