Upstream information

CVE-2006-0747 at MITRE

Description

Integer underflow in Freetype before 2.2 allows remote attackers to cause a denial of service (crash) via a font file with an odd number of blue values, which causes the underflow when decrementing by 2 in a context that assumes an even number of values.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 154928 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • freetype2 >= 2.1.7-53.9
  • freetype2-devel >= 2.1.7-53.9
Builds
YOU Patch Nr: 11059
Novell Linux Desktop 9 for x86_64
  • freetype2 >= 2.1.7-53.9
  • freetype2-32bit >= 9-200606132344
  • freetype2-devel >= 2.1.7-53.9
  • freetype2-devel-32bit >= 9-200606132344
Builds
YOU Patch Nr: 11059
SUSE LINUX 10.0
  • freetype2 >= 2.1.10-4.2
  • freetype2-32bit >= 2.1.10-4.2
  • freetype2-64bit >= 2.1.10-4.2
  • freetype2-devel >= 2.1.10-4.2
  • freetype2-devel-32bit >= 2.1.10-4.2
  • freetype2-devel-64bit >= 2.1.10-4.2
SUSE LINUX 10.1
  • freetype2 >= 2.1.10-18.3
  • freetype2-32bit >= 2.1.10-18.3
  • freetype2-64bit >= 2.1.10-18.3
  • freetype2-devel >= 2.1.10-18.3
  • freetype2-devel-32bit >= 2.1.10-18.3
  • freetype2-devel-64bit >= 2.1.10-18.3
SUSE LINUX 9.2
  • freetype2 >= 2.1.9-3.2
  • freetype2-32bit >= 9.2-200606132154
  • freetype2-devel >= 2.1.9-3.2
  • freetype2-devel-32bit >= 9.2-200606132154
SUSE LINUX 9.3
  • freetype2 >= 2.1.9-4.2
  • freetype2-32bit >= 9.3-7.1
  • freetype2-devel >= 2.1.9-4.2
  • freetype2-devel-32bit >= 9.3-7.1