Upstream information

CVE-2005-3590 at MITRE

Description

The getgrouplist function in the GNU C library (glibc) before version 2.3.5, when invoked with a zero argument, writes to the passed pointer even if the specified array size is zero, leading to a buffer overflow and potentially allowing attackers to corrupt memory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1132195 [RESOLVED / UPSTREAM]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 glibc Analysis
SUSE Linux Enterprise Server 12 SP5 glibc Not affected
SUSE Linux Enterprise Server 12-LTSS glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 glibc Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS glibc Analysis
SLES15-SP1-CHOST-BYOS-Azure glibc Analysis
SLES15-SP1-CHOST-BYOS-EC2 glibc Analysis
SLES15-SP1-CHOST-BYOS-GCE glibc Analysis
SLES15-SP2-CHOST-BYOS-Aliyun glibc Analysis
SLES15-SP2-CHOST-BYOS-Azure glibc Analysis
SLES15-SP2-CHOST-BYOS-EC2 glibc Analysis
SLES15-SP2-CHOST-BYOS-GCE glibc Analysis
SUSE Linux Enterprise High Performance Computing 12 SP4 glibc Not affected
SUSE Linux Enterprise High Performance Computing 15 glibc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 glibc Analysis
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS glibc Analysis
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS glibc Analysis
SUSE Linux Enterprise High Performance Computing 15 SP2 glibc Analysis
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS glibc Analysis
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS glibc Analysis
SUSE Linux Enterprise High Performance Computing 15-ESPOS glibc Analysis
SUSE Linux Enterprise High Performance Computing 15-LTSS glibc Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP1 glibc Analysis
SUSE Linux Enterprise Module for Basesystem 15 SP2 glibc Analysis
SUSE Linux Enterprise Module for Development Tools 15 SP1 glibc Analysis
SUSE Linux Enterprise Module for Development Tools 15 SP2 glibc Analysis
SUSE Linux Enterprise Server 12 SP2-BCL glibc Not affected
SUSE Linux Enterprise Server 12 SP4 glibc Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS glibc Not affected
SUSE Linux Enterprise Server 15 SP1 glibc Analysis
SUSE Linux Enterprise Server 15 SP1-LTSS glibc Analysis
SUSE Linux Enterprise Server 15 SP2 glibc Analysis
SUSE Linux Enterprise Server 15 SP2-LTSS glibc Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 glibc Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP2 glibc Analysis
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 glibc Not affected
Magnum Orchestration 7 glibc Not affected
SLES for SAP Applications 11 SP3 glibc Not affected
SUSE CaaS Platform 3.0 glibc Not affected
SUSE CaaS Platform 4.0 glibc Analysis
SUSE Container as a Service Platform 2.0 glibc Not affected
SUSE Enterprise Storage 6 glibc Analysis
SUSE Linux Enterprise Desktop 11 SP4 glibc Not affected
SUSE Linux Enterprise Desktop 12 glibc Not affected
SUSE Linux Enterprise Desktop 12 SP2 glibc Not affected
SUSE Linux Enterprise Desktop 12 SP3 glibc Not affected
SUSE Linux Enterprise Desktop 12 SP4 glibc Not affected
SUSE Linux Enterprise Desktop 15 glibc Not affected
SUSE Linux Enterprise Desktop 15 SP1 glibc Analysis
SUSE Linux Enterprise Desktop 15 SP2 glibc Analysis
SUSE Linux Enterprise Micro 5.0 glibc Analysis
SUSE Linux Enterprise Module for Basesystem 15 glibc Not affected
SUSE Linux Enterprise Module for Development Tools 15 glibc Not affected
SUSE Linux Enterprise Real Time 15 SP2 glibc Analysis
SUSE Linux Enterprise Server 11 SP3 glibc Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4 glibc Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS glibc Not affected
SUSE Linux Enterprise Server 12 glibc Not affected
SUSE Linux Enterprise Server 12 SP2 glibc Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS glibc Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP3 glibc Not affected
SUSE Linux Enterprise Server 12 SP3-BCL glibc Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS glibc Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS glibc Not affected
SUSE Linux Enterprise Server 15 glibc Not affected
SUSE Linux Enterprise Server 15 SP1-BCL glibc Analysis
SUSE Linux Enterprise Server 15 SP2-BCL glibc Analysis
SUSE Linux Enterprise Server 15-LTSS glibc Analysis
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glibc Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glibc Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 glibc Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 glibc Not affected
SUSE Manager Proxy 4.0 glibc Analysis
SUSE Manager Proxy 4.1 glibc Analysis
SUSE Manager Retail Branch Server 4.0 glibc Analysis
SUSE Manager Retail Branch Server 4.1 glibc Analysis
SUSE Manager Server 4.0 glibc Analysis
SUSE Manager Server 4.1 glibc Analysis
SUSE OpenStack Cloud 7 glibc Not affected
SUSE OpenStack Cloud 8 glibc Not affected
SUSE OpenStack Cloud 9 glibc Not affected
SUSE OpenStack Cloud Crowbar 8 glibc Not affected
SUSE OpenStack Cloud Crowbar 9 glibc Not affected
Container Status
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/sle-micro/5.0/toolbox
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
suse/sles/15.2/virt-api:0.38.1
suse/sles/15.2/virt-controller:0.38.1
suse/sles/15.2/virt-handler:0.38.1
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.2/virt-operator:0.38.1
glibcAnalysis
suse/sles12sp3
suse/sles12sp4
suse/sles12sp5
glibcNot affected


SUSE Timeline for this CVE

CVE page created: Thu Apr 11 00:34:02 2019
CVE page last modified: Fri Jan 20 11:38:31 2023