Upstream information

CVE-2005-3319 at MITRE

Description

The apache2handler SAPI (sapi_apache2.c) in the Apache module (mod_php) for PHP 5.x before 5.1.0 final and 4.4 before 4.4.1 final allows attackers to cause a denial of service (segmentation fault) via the session.save_path option in a .htaccess file or VirtualHost.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 118976 [RESOLVED / FIXED], 130227 [RESOLVED / FIXED], 131579, 131580, 132684 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.46.3
  • apache2-mod_php4 >= 4.3.4-43.46.3
  • mod_php4-core >= 4.3.4-43.46.3
  • mod_php4-servlet >= 4.3.4-43.46.3
  • php4 >= 4.3.4-43.46.3
  • php4-devel >= 4.3.4-43.46.3
  • php4-exif >= 4.3.4-43.46.3
  • php4-fastcgi >= 4.3.4-43.46.3
  • php4-imap >= 4.3.4-43.46.3
  • php4-mysql >= 4.3.4-43.46.3
  • php4-pear >= 4.3.4-43.46.3
  • php4-servlet >= 4.3.4-43.46.3
  • php4-session >= 4.3.4-43.46.3
  • php4-sysvshm >= 4.3.4-43.46.3
suse91.ppc
suse91.s390
sles9-nlpos.x86
YOU Patch Nr: 10712
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.13
  • php5 >= 5.0.3-14.13
  • php5-devel >= 5.0.3-14.13
  • php5-exif >= 5.0.3-14.13
  • php5-fastcgi >= 5.0.3-14.13
  • php5-pear >= 5.0.3-14.13
  • php5-sysvmsg >= 5.0.3-14.13
  • php5-sysvshm >= 5.0.3-14.13
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-495
  • mod_php4-core >= 4.2.2-495
  • mod_php4-devel >= 4.2.2-495
  • mod_php4-servlet >= 4.2.2-495
ul1.x86-64
ul1.s390
slox4,2.x86
ul1.ia64
ul1.ppc
YOU Patch Nr: 10720
SUSE LINUX 10.0
  • apache2-mod_php4 >= 4.4.0-6.2
  • php4 >= 4.4.0-6.2
  • php4-32bit >= 4.4.0-6.2
  • php4-64bit >= 4.4.0-6.2
  • php4-exif >= 4.4.0-6.2
  • php4-fastcgi >= 4.4.0-6.2
  • php4-servlet >= 4.4.0-6.2
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.13
  • mod_php4-servlet >= 4.3.10-14.13
  • php4 >= 4.3.10-14.13
  • php4-32bit >= 9.3-7.6
  • php4-devel >= 4.3.10-14.13
  • php4-exif >= 4.3.10-14.13
  • php4-fastcgi >= 4.3.10-14.13
  • php4-pear >= 4.3.10-14.13
  • php4-session >= 4.3.10-14.13
  • php4-sysvshm >= 4.3.10-14.13
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.2
  • php5 >= 5.0.4-9.2
  • php5-exif >= 5.0.4-9.2
  • php5-fastcgi >= 5.0.4-9.2
  • php5-pear >= 5.0.4-9.2