Upstream information

CVE-2005-2470 at MITRE

Description

Buffer overflow in a "core application plug-in" for Adobe Reader 5.1 through 7.0.2 and Acrobat 5.0 through 7.0.2 allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 105054 [CLOSED], 155313 [RESOLVED / WONTFIX]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux 9.0 for IA32
  • acroread >= 7.0.1-3
SUSE LINUX 9.1 for IA32
  • acroread >= 7.0.1-2.2
SUSE LINUX 9.2
SUSE LINUX 9.3
  • acroread >= 7.0.1-2.1
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • acroread >= 7.0.1-2.2
sles9-nlpos.x86
YOU Patch Nr: 10432
Novell Linux Desktop 9 for x86_64
  • atk >= 1.6.0-2.2
  • atk-32bit >= 9-200508261636
  • atk-doc >= 1.6.0-2.2
  • curl-32bit >= 9-200508261636
  • glib2 >= 2.4.6-0.3
  • glib2-32bit >= 9-200508261636
  • glibc-locale-32bit >= 9-200508261636
  • gtk2 >= 2.4.14-0.5
  • gtk2-32bit >= 9-200508261636
  • gtk2-devel >= 2.4.14-0.5
  • gtk2-doc >= 2.4.14-0.5
  • pango >= 1.4.1-0.2
  • pango-32bit >= 9-200508261636
Builds
YOU Patch Nr: 10453