Upstream information

CVE-2005-0638 at MITRE

Description

xloadimage before 4.1-r2, and xli before 1.17, allows attackers to execute arbitrary commands via shell metacharacters in filenames for compressed images, which are not properly quoted when calling the gunzip command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 66139 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux 8.2 for IA32
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • xli >= 1.17.0-304
SUSE LINUX 9.1 for IA32
  • xli >= 1.17.0-298.2
SUSE LINUX 9.2
  • xli >= 1.17.0-299.2
SUSE LINUX 9.3
  • xli >= 1.17.0-300.2