Upstream information

CVE-2004-1055 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 2.6.0-pl2 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) the PmaAbsoluteUri parameter, (2) the zero_rows parameter in read_dump.php, (3) the confirm form, or (4) an error message generated by the internal phpMyAdmin parser.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux 8.2 for IA32
  • phpMyAdmin >= 2.4.0-77
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • phpMyAdmin >= 2.5.3-38
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • phpMyAdmin >= 2.5.6-34.8
SUSE LINUX 9.2
  • phpMyAdmin >= 2.6.0-4.8
SUSE LINUX 9.3
  • phpMyAdmin >= 2.6.1pl3-4.2